Welcome

Welcome to Agilent N4010A BluetoothÒ EDR TX/RX Measurements DLL Help

Help Revision Date: September 27, 2005

This online help describes how to use the Agilent N4010A Bluetooth EDR TX/RX Measurements DLL. The help is organized into the following sections:

  • Introduction

  • Creating an EDR Test Program – 6 Basic Steps

  • EDR Programming Interface

© Agilent Technologies, Inc. 2005


legal

Legal Information

Acknowledgements

Microsoft® is a U.S. registered trademark of Microsoft Corporation

Windows® and MS Windows® are U.S. registered trademarks of Microsoft Corporation.

Bluetooth® and the Bluetooth Logo are trademarks owned by the Bluetooth SIG, Inc., U.S.A. and licensed to Agilent Technologies, Inc.

Pentium® is a U.S. registered trademark of Intel Corporation.

Notices

©Agilent Technologies, Inc. 2005

No part of this manual may be reproduced in any form or by any means (including electronic storage and retrieval or translation into a foreign language) without prior agreement and written consent from Agilent Technologies, Inc. as governed by United States and international copyright laws.

The N4010A is listed as a Development Tool for Bluetooth SIG purposes.

Edition

First Edition, September 2005

Printed in UK

Agilent Technologies, Inc.
EMG Learning Products,
South Queensferry,
EH30 9TG
United Kingdom

Warranty

The material contained in this document is provided “as is,” and is subject to being changed, without notice, in future editions. Further, to the maximum extent permitted by applicable law, Agilent disclaims all warranties, either express or implied, with regard to this manual and any information contained herein, including but not limited to the implied warranties of merchantability and fitness for a particular purpose. Agilent shall not be liable for errors or for incidental or consequential damages in connection with the furnishing, use, or performance of this document or of any information contained herein. Should Agilent and the user have a separate written agreement with warranty terms covering the material in this document that conflict with these terms, the warranty terms in the separate agreement shall control.

Technology Licenses

The hardware and/or software described in this document are furnished under a license and may be used or copied only in accordance with the terms of such license.

Restricted Rights Legend

If software is for use in the performance of a U.S. Government prime contract or subcontract, Software is delivered and licensed as “Commercial computer software” as defined in DFAR 252.227-7014 (June 1995), or as a “commercial item” as defined in FAR 2.101(a) or as “Restricted computer software” as defined in FAR 52.227-19 (June 1987) or any equivalent agency regulation or contract clause. Use, duplication or disclosure of Software is subject to Agilent Technologies’ standard commercial license terms, and non-DOD Departments and Agencies of the U.S. Government will receive no greater than Restricted Rights as defined in FAR 52.227-19(c)(1-2) (June 1987). U.S. Government users will receive no greater than Limited Rights as defined in FAR 52.227-14 (June 1987) or DFAR 252.227-7015 (b)(2) (November 1995), as applicable in any technical data.


Overview of Bluetooth EDR Measurements

The following Bluetooth 2.0 transmitter measurements use measurement algorithms that are in full compliance with the Bluetooth RF Test Specification.

  • Differential Phase Encoding: This test verifies that the EUT modulator correctly differential phase encodes its baseband payload data.

  • Carrier Stability: calculates the frequency accuracy of the frequency modulated [GFSK] and phase modulated [DPSK] portions of the measured packet.

  • Modulation Accuracy: This calculates the Differential Error Vector Magnitude [DEVM] of the phase modulated portion of the measured packet.

  • Relative Transmit Power: Referenced to BitP0, the Relative Transmit Power calculates the difference between average transmit power during frequency modulated [GFSK] and phase modulated [DPSK] portions of a packet.

For more detail on these Bluetooth 2.0 transmitter measurements refer to the Bluetooth RF Test Specification.

F


Test Set Requirements

  • N4010A instrument with Options 101 Bluetooth and 105 or 106

  • Connection between the N4010A and the PC via LAN or USB

  • A Bluetooth Enhanced Date Rate (EDR) device

  • Connection between Bluetooth EDR device RF port and N4010A RF In/Out

  • Installation of the N4010A EDR Test Driver

  • The Bluetooth Enhanced Data Rate device control software

  • Installation and experience in a programming environment, for example Microsoft C# .NET, Microsoft Visual Basic, Agilent VEE, or NI LabVIEW.


Installing the N4010A Bluetooth EDR TX/RX Measurements DLL

To install the N4010A Bluetooth EDR TX/RX Measurements DLL refer to the Getting Started Guide.


DLL Compatibility

During the installation of the N4010A N4010A Bluetooth EDR TX/RX Measurements DLL there are two programming interfaces installed:

  • COM DLL

  • .NET DLL

These give you the option to use the DLL type that is compatible with your software development environment.

The COM and .NET programming interfaces are compatible with any programming language that supports either COM or .NET DLL programming. Example programs are available for:

  • Microsoft Visual C# .NET (COM and .NET)

  • Microsoft Visual Basic .NET (COM and .NET)

  • Microsoft Visual Basic 6.0 (COM)

  • Microsoft Visual C++ 6.0 (COM)

  • Agilent VEE 6.2 (COM)

  • Agilent VEE 7.0 (COM and .NET)

  • LabVIEW 6 (COM)

  • LabVIEW 7.1 (COM and .NET)


Creating an EDR Test Program

Overview of the 6 Steps

There are six basic steps in creating an EDR test program using the N4010A EDR COM or .NET DLL.

  1. Reference the Dynamic Link Library’s (DLL’s)

  2. Create the Instrument Object

  3. Configure the Measurement Setup Parameters

  4. Run the Measurement

  5. Get the Measurement Results

  6. Close the Session

Steps 3 to 5 can be repeated as many times as required for a full test of the Bluetooth EDR device. There is no need to follow step 1 “Create” and step 6 “Dispose” of the Instrument object for each measurement. The “Create” and “Dispose” stages are only required if the PC or the N4010A is power cycled.

It is advisable during software test development / debugging to catch any potential exceptions due to potential errors in the programming or setup. For example the use of Try / Catch Blocks in Microsoft Visual Studio .NET, allows the program to catch any errors without the program aborting. Additionally, if the program aborts due to an exception the “Dispose” method may not be reached and the N4010A can be left in an unknown state.


Step 1 Reference the Dynamic Link Library (DLL)

For development programming environments such as the Microsoft Visual Studio Integrated Development Environment (IDE), the programming language needs to first reference the N4010A Bluetooth EDR TX/RX Measurement COM, or .NET, DLLs. How this is done varies between development environments. Additionally, there are some minor differences between whether the .NET or COM DLLs are used which is described in the next section.

There are two N4010A DLL references required:

  1. Agilent.N4010.dll

  2. Agilent.N4010.EdrDriver.dll

The N4010A EDR “Test Driver” DLLs above are registered in the Windows Registry. Among other things, this enables programs such as Visual Studio .NET to present the DLL in the references list for easy selection.

Example: Referencing the EDR DLL’s in Visual Studio .NET

Select the Project, Add Reference... menu.

  • The default .NET tab shows a list of assemblies, this is where the .NET DLL is listed.

  • The COM tab is where the COM DLLs are listed. This tab should also be familiar to Visual Basic 6 users who reference a COM component's type library the same way (using the Project, References... menu in the Visual Basic 6.0 IDE).

When referencing a COM component, you are actually referencing its type library, which provides the development environment compiler with definitions of types, methods, and properties that the component exposes.

Example: Referencing the EDR DLLs in Agilent VEE

  • COM DLL:

From the file menu, click: Select Device, Active X Automation References

  • .NET DLL:

From the file menu, click: Select Device, .NET Assembly References

Example: Referencing the EDR DLLs in NI LabVIEW

  • .NET DLL:

From the file menu, click: Select Tools, Advanced, .NET Assembly References, click Add and Browse to DLLs


Step 2 Create the Instrument Object

Each program begins with the creation of the N4010A instrument object. You must create the instrument object before you can access the test set functionality through the EdrDriver DLL methods (functions) and properties (parameters). The methods required to create the object differ between the .NET DLL and the COM DLL as described below:

.NET object creation

The N4010A .NET EDR DLL interface provides an Instrument "constructor". The Instrument constructor allows the creation of a new Agilent N4010A EDR Test driver object, or specifically the Instrument object. Having a constructor means that an Instrument object can be created with some constructor pre-initialized parameters.

There is more than one constructor providing flexibility in the setting of parameters at the object creation stage. The minimum requirement on creation / construction of the Instrument object is the VISA resource address of the N4010A, specified by InstrumentVISAString property, to setup communication between the PC and the N4010A over LAN or USB.

The constructor text below is not an example of how to program the constructor; it is a template for the constructor to show the properties that can be set during the creation / construction of the object.

EDR .NET DLL constructor:

public Instrument(

string InstrumentVISAString,

bool ShowSplash,

bool DeleteAllFiles,

bool LoadEdrFiles

);

This constructor specifies:

  • The instrument VISA name - InstrumentVISAString of the Agilent N4010A device.

  • Splash screen - show/don't show splash screen.

  • Delete all files - sequence files reside in non-volatile instrument memory - set the value to true to ensure you delete any previous files.

  • Load EDR Files - Setting this value to true means that all required sequence and segment files are loaded into the instrument non-volatile memory during startup if they do not already exist in the instrument memory.

IMPORTANT: The first time the N4010A test set has been used during the EDR DLL object creation results in a two to three minute delay. This delay is due to the downloading of EDR waveform files. Any further object creation using the same N4010A test set will not have this delay as the files already exist within the N4010A non-volatile memory and is not downloaded again.

Example code: .NET Object creation (C# .NET syntax)

// Create the instrument object named Inst from the Instrument Class

Agilent.N4010.EdrDriver.Instrument Inst =

new Instrument("TCPIP0::12.34.56.78::inst0::INSTR",true,true,true);

Refer to the N4010A help file Agilent.N4010.EdrDriver.Instrument Class for detailed information.

COM object creation:

The N4010A COM EDR DLL interface does not provide an Instrument “constructor” like the .NET EDR DLL does. As with the .NET Instrument object creation, the creation of the N4010A EDR COM Test driver object requires as a minimum the VISA address of the N4010A specified by InstrumentVISAString, to setup communication between the PC and the N4010A over LAN or USB. However, the primary difference with the COM object creation and the .NET object creation is that on setting this parameter, or any other initial parameters, the instrument object is still not created until a method named ActivateInstrument() is called. This is the equivalent of a constructor in that once any initial parameters have been set; this method creates the Instrument object with the desired initial parameters.

Example code: COM object creation (C# syntax)

// Create the instrument object named Inst

Agilent_N4010_EdrDriver.Instrument Inst = new Instrument();

Inst.InstrumentVISAResourceString = "TCPIP0::12.34.56.78";

Inst.ShowSplashScreen = true;

Inst.LoadEdrFiles = true;

Inst.ActivateInstrument();


Step 3 Configure the Measurement Setup Parameters

Change the test set settings to suit the Bluetooth device and the measurement, for example measurement ChannelFrequency and TriggerLevel values.

Generic N4010A Measurement Setup Parameters

Refer to the N4010A help file Agilent.N4010.EdrDriver.Measurements.MeasurementSetup Class for the default settings and ranges for generic parameters such as ChannelFrequency, TriggerLevel, expected maximum input PowerRange, and ExpectedPacketType. Ensure the triggering and measurement settings are setup as appropriate for the signal being transmitted into the N4010A test set, from the Bluetooth EDR device, otherwise the measurement will timeout on detecting no signal.

Measurement Specific N4010A Setup Parameters

Refer to the N4010A help file Agilent.N4010.EdrDriver.Measurements.Settings Class for default settings and ranges for measurement specific settings, for example, the NumberOfPackets property is unique to the DifferentialPhaseEncoding test.

Bluetooth EDR Device Setup Parameters

The Bluetooth device must be in the correct condition for the measurement you are making. For the Bluetooth EDR Tx / Rx solution the setup of the Bluetooth device is not controlled by the test set or the programming interface and is controlled through the chipset vendor specific control software.

Example code: Measurement setup (C# syntax)

// Configure the generic measurement setup parameters

Inst.MeasurementSetup.ChannelFrequency = 2441000000;

Inst.MeasurementSetup.PowerRange = 0.0;

Inst.MeasurementSetup.TriggerStyle =

Agilent.N4010.EdrDriver.Enums.TriggerStyle.Burst

Inst.MeasurementSetup.TriggerLevel = -5.0;

Inst.MeasurementSetup.TriggerIdle = 0.0001;

Inst.MeasurementSetup.AcquisitionTime = 0.001;

// Configure the measurement specific setup parameters

Inst.DifferentialPhaseEncoding.Settings.NumberOfPackets = 50;


Step 4 Perform the Test

Measurement Run() Methods

The collecting of measurement data and the running of measurements can be started by using the measurement Run() methods.

Refer to the N4010A help file Agilent.N4010.EdrDriver.Measurements Class for the full list of N4010A EDR transmitter measurements.

Measurement CalcResults() Methods

There are also available measurement CalcResults() methods that allow the calculation of measurement results from the data captured from the previously run measurement, this is very useful in saving test time. For example, if a Differential Phase Encoding Run() method has previously been called this will have collected data and calculated measurement results for the Differential Phase Encoding measurement. If the RelativePower CalcResults() method is then called this will not have to re-collect data and will calculate measurement results from the last packet from previously captured data.

Example code: Running of measurement (C# syntax)

// Run the Differential Phase Encoding measurement

Inst. DifferentialPhaseEncoding.Run();

// Calculate Relative Power results from the previously captured data

Inst.RelativePower.CalcResults();


Step 5 Getting the Measurement Results

In the example the relative power measurement includes several properties for retrieval of individual results including AveragePowerDifference, GFSKPower, DPSKPower, CalculatedPacketType, ConstellationVector, GuardInterval, and Power.

Example code: Retrieval of measurement results (C# syntax)

// Get the Differential Phase Encoding measurement results

NumberPackets = Inst.DifferentialPhaseEncoding.Results.NumberPackets;

NumberCorrectPackets =

Inst.DifferentialPhaseEncoding.Results.NumberCorrectPackets;

ErroredPackets.Text = (NumberPackets - NumberCorrectPackets);

// Get the Relative Power measurement results

RelPower = Inst.RelativePower.Results.AveragePowerDifference;

GFSKPower = Inst.RelativePower.Results.AveragePowerGfsk;

DPSKPower = Inst.RelativePower.Results.AveragePowerDpsk;

PacketType = Inst.RelativePower.Results.CalculatedPacketType;

EDR Receiver Measurements

Bluetooth EDR Receiver testing is performed through the use of the N4010A Signal Generator and sending known Bluetooth EDR packet types and monitoring the performance of the Bluetooth device through its vendor specific control software.

Refer to the N4010A help file Agilent.N4010.EdrDriver.Generator Class for the default settings and ranges for parameters such as ChannelFrequencyOutput, and PacketType of the N4010A signal generator.

Example code: Setup and Running of the N4010A Signal Generator (C# syntax)

// Get the selected filename

Inst.Generator.PacketType =

Agilent.N4010.EdrDriver.Enums.TransmitPacketType.TwoDH1;

//Set the N4010A Output Frequency

Inst.Generator.ChannelFrequencyOuput = 2441000000;

//Set the N4010A Tx Power Level

Inst.Generator.Level = -40.0;

//Start N4010A Transmission / Generation

Inst.Generator.Start();

//Stop the N4010A Transmission / Generation

Inst.Generator.Stop();


Step 6 Close the Session

End the program and release the test set using the Dispose() method. As well as releasing memory space used by the EDR DLLs this also releases the handle on the InstrumentVISAString allowing communication with the test set through other means.

// Close the session

Inst.Dispose();


EDR Programming Interface

The following information is the commands for the .NET programming interface.


Agilent.N4010.EdrDriver

Agilent N4010A Bluetooth EDR Driver

Agilent.N4010.EdrDriver Namespace

Namespace hierarchy

Classes

Class | Description
DebugLogEventArgs | Class that uses events to record any debug
Instrument | Encapsulates and implements the functionality of the Agilent N4010 EdrDriver programming interface.

Delegates

Delegate | Description
DebugLogEventHandler | delegate for Debug log

Enumerations

Enumeration | Description
DebugLogSeverity | This enum defines debug logging levels. It is assumed that a high-value log level also records all lower level logging points (ie if you ask for TRACEPOINT, you get everything else).

(C) Copyright 2004-2005 Agilent Technologies, Inc


DebugLogEventArgs Class

Class that uses events to record any debug

For a list of all members of this type, see DebugLogEventArgs Members.

System.Object
System.EventArgs
Agilent.N4010.EdrDriver.DebugLogEventArgs

public class DebugLogEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Agilent.N4010.EdrDriver

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

DebugLogEventArgs Members | Agilent.N4010.EdrDriver Namespace


DebugLogEventArgs Members

DebugLogEventArgs overview

Public Instance Constructors

DebugLogEventArgs Constructor constructor for debug log

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | ToString overriden to allow insertion of time into message

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DebugLogEventArgs Class | Agilent.N4010.EdrDriver Namespace


DebugLogEventArgs Constructor

constructor for debug log

public DebugLogEventArgs(
DebugLogSeverity Sev,
string Text
);

Parameters

Sev
Text

See Also

DebugLogEventArgs Class | Agilent.N4010.EdrDriver Namespace


DebugLogEventArgs Methods

The methods of the DebugLogEventArgs class are listed below. For a complete list of DebugLogEventArgs class members, see the DebugLogEventArgs Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | ToString overriden to allow insertion of time into message

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DebugLogEventArgs Class | Agilent.N4010.EdrDriver Namespace


DebugLogEventArgs.ToString Method

ToString overriden to allow insertion of time into message

public override string ToString();

Return Value

See Also

DebugLogEventArgs Class | Agilent.N4010.EdrDriver Namespace


DebugLogEventHandler Delegate

delegate for Debug log

public delegate void DebugLogEventHandler(
object sender,
DebugLogEventArgs e
);

Requirements

Namespace: Agilent.N4010.EdrDriver

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

Agilent.N4010.EdrDriver Namespace


DebugLogSeverity Enumeration

This enum defines debug logging levels. It is assumed that a high-value log level also records all lower level logging points (ie if you ask for TRACEPOINT, you get everything else).

public enum DebugLogSeverity

Members

Member Name | Description
CRITICAL | Only log critical events
EXCEPTION | Log all exceptions
ENTRYPOINT | Log entry/exit to functions
BRANCHPOINT | Log all brahchpoints within functions
TRACEPOINT | Log everything

Requirements

Namespace: Agilent.N4010.EdrDriver

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

Agilent.N4010.EdrDriver Namespace


Instrument Class

Encapsulates and implements the functionality of the Agilent N4010 EdrDriver programming interface.

For a list of all members of this type, see Instrument Members.

System.Object
Agilent.N4010.EdrDriver.Instrument

public class Instrument

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

You must create the instrument before you can access any of the N4010's functionality.

Requirements

Namespace: Agilent.N4010.EdrDriver

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

Instrument Members | Agilent.N4010.EdrDriver Namespace


Instrument Members

Instrument overview

Public Instance Constructors

Instrument Overloaded. Initializes a new instance of the Instrument class.

Public Instance Properties

BasebandIq |
CarrierStabilityModulationAccuracy |
DataMarkers |
DifferentialPhaseEncoding |
Generator | Reference used to return Rx Test
MeasurementRunning |
MeasurementSetup |
Power |
RelativePower |
ScpiPassThru |

Public Instance Methods

Dispose | Dispose of resources owned by the Agilent N4010 edrDriver programming interface object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

DebugLog DebugLog event handler

Protected Instance Methods

Finalize | Destroy the Agilent N4010 edrDriver programming interface object.
GetInstrumentAndLicensingInfo | Return the VISA Resource string associated with the instrument given as a parameter. If the instrument is not suitable for use, return null.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Instrument Class | Agilent.N4010.EdrDriver Namespace


Instrument Constructor

Construct a new Agilent N4010 EDR programming interface object.

Overload List

Construct a new Agilent N4010 EDR programming interface object.

public Instrument(string);

Construct a new Agilent N4010 EDR programming interface object.

public Instrument(string,bool,bool,bool);

See Also

Instrument Class | Agilent.N4010.EdrDriver Namespace


Instrument Constructor (String)

Construct a new Agilent N4010 EDR programming interface object.

public Instrument(
string InstrumentVISAString
);

Parameters

InstrumentVISAString
VISA resource name of Agilent N4010A device

Remarks

Using this overload, you can set certain parameters of the instrument's operation.

See Also

Instrument Class | Agilent.N4010.EdrDriver Namespace | Instrument Constructor Overload List


Instrument Constructor (String, Boolean, Boolean, Boolean)

Construct a new Agilent N4010 EDR programming interface object.

public Instrument(
string InstrumentVISAString,
bool ShowSplash,
bool DeleteAllFiles,
bool LoadEdrFiles
);

Parameters

InstrumentVISAString
VISA resource name of Agilent N4010A device
ShowSplash
  • true - show splash screen
  • false - do not show splash screen
DeleteAllFiles
  • true - delete all files
  • false - do not delete all files
Setting this value true means that all sequence and segment files will be deleted from the instrument during startup, and you can work from a known state. Setting it false means that the files will not be deleted.
LoadEdrFiles
  • true- load EDR sequence and segment files
  • false- do not load EDR sequence and segment files
Loads the required sequence and segment files in non-volatile memory. Setting this value true means that all the files will be loaded to the instrument during startup. Setting it false means that the files will not be loaded. Note that the Generator's operation is dependent on the correct segment and sequence files being located on the instrument.

Remarks

Using this overload, you can set certain parameters of the instrument's operation.

See Also

Instrument Class | Agilent.N4010.EdrDriver Namespace | Instrument Constructor Overload List


Instrument Properties

The properties of the Instrument class are listed below. For a complete list of Instrument class members, see the Instrument Members topic.

Public Instance Properties

BasebandIq |
CarrierStabilityModulationAccuracy |
DataMarkers |
DifferentialPhaseEncoding |
Generator | Reference used to return Rx Test
MeasurementRunning |
MeasurementSetup |
Power |
RelativePower |
ScpiPassThru |

See Also

Instrument Class | Agilent.N4010.EdrDriver Namespace


BasebandIq Property

Agilent N4010A Bluetooth EDR Driver

Instrument.BasebandIq Property

public Measurements.BasebandIq BasebandIq {get;}

See Also

Instrument Class | Agilent.N4010.EdrDriver Namespace


CarrierStabilityModulationAccuracy Property

Agilent N4010A Bluetooth EDR Driver

Instrument.CarrierStabilityModulationAccuracy Property

public Measurements.CarrierStabilityModulationAccuracy CarrierStabilityModulationAccuracy {get;}

See Also

Instrument Class | Agilent.N4010.EdrDriver Namespace


DataMarkers Property

Agilent N4010A Bluetooth EDR Driver

Instrument.DataMarkers Property

public Measurements.DataMarkers DataMarkers {get;}

See Also

Instrument Class | Agilent.N4010.EdrDriver Namespace


DifferentialPhaseEncoding Property

Agilent N4010A Bluetooth EDR Driver

Instrument.DifferentialPhaseEncoding Property

public Measurements.DifferentialPhaseEncoding DifferentialPhaseEncoding {get;}

See Also

Instrument Class | Agilent.N4010.EdrDriver Namespace


Generator Property

Agilent N4010A Bluetooth EDR Driver

Instrument.Generator Property

Reference used to return Rx Test

public Generator.Generator Generator {get;}

See Also

Instrument Class | Agilent.N4010.EdrDriver Namespace


MeasurementRunning Property

Agilent N4010A Bluetooth EDR Driver

Instrument.MeasurementRunning Property

public bool MeasurementRunning {get;}

See Also

Instrument Class | Agilent.N4010.EdrDriver Namespace


MeasurementSetup Property

Agilent N4010A Bluetooth EDR Driver

Instrument.MeasurementSetup Property

public Measurements.MeasurementSetup MeasurementSetup {get;}

See Also

Instrument Class | Agilent.N4010.EdrDriver Namespace


Power Property

Agilent N4010A Bluetooth EDR Driver

Instrument.Power Property

public Measurements.Power Power {get;}

See Also

Instrument Class | Agilent.N4010.EdrDriver Namespace


RelativePower Property

Agilent N4010A Bluetooth EDR Driver

Instrument.RelativePower Property

public Measurements.RelativePower RelativePower {get;}

See Also

Instrument Class | Agilent.N4010.EdrDriver Namespace


ScpiPassThru Property

Agilent N4010A Bluetooth EDR Driver

Instrument.ScpiPassThru Property

public Agilent.N4010.DirectIO ScpiPassThru {get;}

See Also

Instrument Class | Agilent.N4010.EdrDriver Namespace


Instrument Methods

The methods of the Instrument class are listed below. For a complete list of Instrument class members, see the Instrument Members topic.

Public Instance Methods

Dispose | Dispose of resources owned by the Agilent N4010 edrDriver programming interface object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize | Destroy the Agilent N4010 edrDriver programming interface object.
GetInstrumentAndLicensingInfo | Return the VISA Resource string associated with the instrument given as a parameter. If the instrument is not suitable for use, return null.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Instrument Class | Agilent.N4010.EdrDriver Namespace


Instrument.Dispose Method

Dispose of resources owned by the Agilent N4010 edrDriver programming interface object.

public void Dispose();

Remarks

Do not attempt to access the instrument after calling this method - it's gone!

See Also

Instrument Class | Agilent.N4010.EdrDriver Namespace


Instrument.Finalize Method

Destroy the Agilent N4010 edrDriver programming interface object.

protected override void Finalize();

Remarks

See Also

Instrument Class | Agilent.N4010.EdrDriver Namespace


Instrument.GetInstrumentAndLicensingInfo Method

Return the VISA Resource string associated with the instrument given as a parameter. If the instrument is not suitable for use, return null.

protected virtual string GetInstrumentAndLicensingInfo(
string InstrumentVISAString
);

Return Value

The VISA Resource String of an appropriate instrument, otherwise null.

Remarks

This code can only run against an Agilent N4010A with option H01.

The intention is that at a future date this code can, if given a null string, search through the IO libraries for something it is willing to play with.

See Also

Instrument Class | Agilent.N4010.EdrDriver Namespace


Instrument Events

The events of the Instrument class are listed below. For a complete list of Instrument class members, see the Instrument Members topic.

Public Instance Events

DebugLog DebugLog event handler

See Also

Instrument Class | Agilent.N4010.EdrDriver Namespace


Instrument.DebugLog Event

DebugLog event handler

public event DebugLogEventHandler DebugLog;

See Also

Instrument Class | Agilent.N4010.EdrDriver Namespace


Agilent.N4010.EdrDriver.Enums

Agilent N4010A Bluetooth EDR Driver

Agilent.N4010.EdrDriver.Enums Namespace

Namespace hierarchy

Enumerations

Enumeration | Description
CalculatedEdrPacketType | Enum to return the calculated EDR packet type.
ExpectedPacketType | Packet Type enum for EDR packets. Defined for asynchronous logical transport types.
IFBandwidth | Defines the IF Bandwidth for the instrument
TransmitPacketType | Packet Type to be transmitted. Allows transmission of the loaded custom file.
TriggerSlope | Enus to control trigger slope
TriggerStyle | Enum to control the trigger style used by the called subsystems.


CalculatedEdrPacketType Enumeration

Enum to return the calculated EDR packet type.

public enum CalculatedEdrPacketType

Members

Member Name | Description
TwoDH1 | 2-DH1 packet
TwoDH3 | 2-DH3 packet
TwoDH5 | 2-DH5 packet
ThreeDH1 | 3-DH1 packet
ThreeDH3 | 3-DH3 packet
ThreeDH5 | 3-DH5 packet
Other | Any other packet type
None | No EDR Packet type detected.

Requirements

Namespace: Agilent.N4010.EdrDriver.Enums

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

Agilent.N4010.EdrDriver.Enums Namespace


ExpectedPacketType Enumeration

Packet Type enum for EDR packets. Defined for asynchronous logical transport types.

public enum ExpectedPacketType

Members

Member Name | Description
TwoDH1 | 2-DH1 packet
TwoDH3 | 2-DH3 packet
TwoDH5 | 2-DH5 packet
ThreeDH1 | 3-DH1 packet
ThreeDH3 | 3-DH3 packet
ThreeDH5 | 3-DH5 packet

Requirements

Namespace: Agilent.N4010.EdrDriver.Enums

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

Agilent.N4010.EdrDriver.Enums Namespace


IFBandwidth Enumeration

Defines the IF Bandwidth for the instrument

public enum IFBandwidth

Members

Member Name | Description
IF_1_3MHz | IF bandwidth of 1.3MHz
IF_3MHz | IF bandwidth of 3MHz
IF_5MHz | IF bandwidth of 5MHz

Requirements

Namespace: Agilent.N4010.EdrDriver.Enums

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

Agilent.N4010.EdrDriver.Enums Namespace


TransmitPacketType Enumeration

Packet Type to be transmitted. Allows transmission of the loaded custom file.

public enum TransmitPacketType

Members

Member Name | Description
CustomFile | The custom file loaded onto the N4010A.
TwoDH1 | 2-DH1 packet
TwoDH3 | 2-DH3 packet
TwoDH5 | 2-DH5 packet
ThreeDH1 | 3-DH1 packet
ThreeDH3 | 3-DH3 packet
ThreeDH5 | 3-DH5 packet

Requirements

Namespace: Agilent.N4010.EdrDriver.Enums

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

Agilent.N4010.EdrDriver.Enums Namespace


TriggerSlope Enumeration

Enus to control trigger slope

public enum TriggerSlope

Members

Member Name | Description
Positive | Triggers on positive slope
Negative | Triggers on negative slope

Requirements

Namespace: Agilent.N4010.EdrDriver.Enums

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

Agilent.N4010.EdrDriver.Enums Namespace


TriggerStyle Enumeration

Enum to control the trigger style used by the called subsystems.

public enum TriggerStyle

Members

Member Name | Description
Burst | Burst Trigger
External | External trigger

Requirements

Namespace: Agilent.N4010.EdrDriver.Enums

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

Agilent.N4010.EdrDriver.Enums Namespace | TriggerStyle


Agilent.N4010.EdrDriver.Exceptions

Agilent N4010A Bluetooth EDR Driver

Agilent.N4010.EdrDriver.Exceptions Namespace

Namespace hierarchy

Classes

Class | Description
AcquisitionOffsetTimeOutOfRangeException | Thrown when an attempt is made to set Trigger Delay outside the valid range.
AcquisitionTimeOutOfRangeException | Thrown when an attempt is made to set AcquisitionTime outside the valid range.
ArbitraryWaveformGeneratorException | Thrown when an error is reported by the AWG instrument.
CannotConnectToInstrumentException | Thrown when a connection cannot be made to the instrument
ChannelFrequencyOutOfRangeException | Thrown when an attempt is made to set to a frequency outside the valid range.
EdrOutputLevelOutOfRangeException | Thrown when an attempt is made to set the Arbitrary Waveform Generator to a level outwith its valid range.
ExpectedPacketTypeOutOfRangeException | Thrown when an attempt is made to set to the expected packet type outside the valid range.
FailedToStartException | Thrown when starting a new instance of the Agilent.N4010.EdrDriver.Instrument class. Text may provide further information
FileStoreFullException | Thrown when an attempt is made to download a sequence or segment file or file set for which there is not enough free space.
FrequencyOutOfRangeException | Thrown when an attempt is made to set the output frequency outside the valid range.
IFBandwidthOutOfRangeException | Thrown when an attemps is made to set the IF bandwidth to an invalid value.
InternalErrorException | Thrown when an public error occurs
InvalidFileNameException | Thrown when an attempt is made to load or save a file with an invalid name.
InvalidParameterException | Thrown when a call was made with an invalid parameter.
MeasurementErrorException | Thrown when the measurement returns an error.
MeasurementRunningException | Thrown when you try to perform an operation, but a Measurement is already running on the N4010.
MeasurementTimeoutException | Thrown when a measurement reports a timeout
MeasurementTimeoutOutOfRangeException | Thrown when an attempt is made to set an invalid measurement timeout
MissingSegmentFileException | Thrown when trying to select a sequence file that contains references to one or more segment files that do not exist on the instrument
NoIQData | Thrown when trying to save IQ data when no IQ data has been received
NoSequenceFileSelectedException | Thrown when an attempt is made to Trigger the AWG without a sequence file selected.
NoSuchInstrumentFileException | Thrown when trying to access a file where the name already does not exist on the hardware instrument.
NotLicensedException | Thrown when an attempt is made to perform an operation that is not licensed
OutputLevelOutOfRangeException | Thrown when an attempt is made to set the Arbitrary Waveform Generator to a level outwith its valid range.
PacketNumberOutOfRangeException | Thrown when an attempt is made to set to the numbber of packets outside the valid range.
PowerLevelOutOfRangeException | Thrown when an attempt is made to set to a power range outside the valid range.
ResultNotAvailableException | Thrown when a query is made for a measurement result but no result is available
SourceActiveException | Thrown when you try to perform an operation, but the source is already running on the N4010.
SourceInactiveException | Thrown when you try to perform an operation, but the source is not currently running on the N4010.
TriggerIdleOutOfRangeException | Thrown when an attempt is made to set Trigger Idle outside the valid range.
TriggerLevelOutOfRangeException | Thrown when an attempt is made to set to a trigger level outside the valid range.
TriggerSlopeOutOfRangeException | Thrown when an attempt is made to set Trigger Slope outside the valid range.
TriggerStyleOutOfRangeException | Thrown when an attempt is made to set Trigger Style outside the valid range.
VisaException | Thrown when an error is reported by the VISA subsystem


AcquisitionOffsetTimeOutOfRangeException Class

Thrown when an attempt is made to set Trigger Delay outside the valid range.

For a list of all members of this type, see AcquisitionOffsetTimeOutOfRangeException Members.

System.Object
System.Exception
System.ApplicationException
Agilent.N4010.EdrDriver.Exceptions.InvalidParameterException
Agilent.N4010.EdrDriver.Exceptions.AcquisitionOffsetTimeOutOfRangeException

public class AcquisitionOffsetTimeOutOfRangeException : InvalidParameterException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

-

Requirements

Namespace: Agilent.N4010.EdrDriver.Exceptions

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

AcquisitionOffsetTimeOutOfRangeException Members | Agilent.N4010.EdrDriver.Exceptions Namespace


AcquisitionOffsetTimeOutOfRangeException Members

AcquisitionOffsetTimeOutOfRangeException overview

Public Instance Constructors

AcquisitionOffsetTimeOutOfRangeException Constructor Constructor for AcquisitionOffsetTimeOutOfRangeException, explanatory string provided

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AcquisitionOffsetTimeOutOfRangeException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


AcquisitionOffsetTimeOutOfRangeException Constructor

Constructor for AcquisitionOffsetTimeOutOfRangeException, explanatory string provided

public AcquisitionOffsetTimeOutOfRangeException(
string Detail
);

See Also

AcquisitionOffsetTimeOutOfRangeException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


AcquisitionTimeOutOfRangeException Class

Thrown when an attempt is made to set AcquisitionTime outside the valid range.

For a list of all members of this type, see AcquisitionTimeOutOfRangeException Members.

System.Object
System.Exception
System.ApplicationException
Agilent.N4010.EdrDriver.Exceptions.InvalidParameterException
Agilent.N4010.EdrDriver.Exceptions.AcquisitionTimeOutOfRangeException

public class AcquisitionTimeOutOfRangeException : InvalidParameterException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Agilent.N4010.EdrDriver.Exceptions

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

AcquisitionTimeOutOfRangeException Members | Agilent.N4010.EdrDriver.Exceptions Namespace


AcquisitionTimeOutOfRangeException Members

AcquisitionTimeOutOfRangeException overview

Public Instance Constructors

AcquisitionTimeOutOfRangeException Constructor Constructor for AcquisitionTimeOutOfRangeException, explanatory string provided

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AcquisitionTimeOutOfRangeException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


AcquisitionTimeOutOfRangeException Constructor

Constructor for AcquisitionTimeOutOfRangeException, explanatory string provided

public AcquisitionTimeOutOfRangeException(
string Detail
);

See Also

AcquisitionTimeOutOfRangeException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


ArbitraryWaveformGeneratorException Class

Thrown when an error is reported by the AWG instrument.

For a list of all members of this type, see ArbitraryWaveformGeneratorException Members.

System.Object
System.Exception
System.ApplicationException
Agilent.N4010.EdrDriver.Exceptions.ArbitraryWaveformGeneratorException

public class ArbitraryWaveformGeneratorException : ApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

See the description of the function that was called for more information.

Requirements

Namespace: Agilent.N4010.EdrDriver.Exceptions

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

ArbitraryWaveformGeneratorException Members | Agilent.N4010.EdrDriver.Exceptions Namespace


ArbitraryWaveformGeneratorException Members

ArbitraryWaveformGeneratorException overview

Public Instance Constructors

ArbitraryWaveformGeneratorException Constructor Constructor for NoSuchInstrumentFileException, explanatory string provided

Public Instance Properties

ErrorMessage | Error message returned by Agilent N4010 instrument
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArbitraryWaveformGeneratorException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


ArbitraryWaveformGeneratorException Constructor

Constructor for NoSuchInstrumentFileException, explanatory string provided

public ArbitraryWaveformGeneratorException(
string Error
);

See Also

ArbitraryWaveformGeneratorException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


ArbitraryWaveformGeneratorException Properties

The properties of the ArbitraryWaveformGeneratorException class are listed below. For a complete list of ArbitraryWaveformGeneratorException class members, see the ArbitraryWaveformGeneratorException Members topic.

Public Instance Properties

ErrorMessage | Error message returned by Agilent N4010 instrument
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

ArbitraryWaveformGeneratorException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


ErrorMessage Property

Agilent N4010A Bluetooth EDR Driver

ArbitraryWaveformGeneratorException.ErrorMessage Property

Error message returned by Agilent N4010 instrument

public string ErrorMessage {get;}

Property Value

Error message returned by Agilent N4010 instrument

Remarks

This string is the error message returned by the instrument.

See Also

ArbitraryWaveformGeneratorException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


CannotConnectToInstrumentException Class

Thrown when a connection cannot be made to the instrument

For a list of all members of this type, see CannotConnectToInstrumentException Members.

System.Object
System.Exception
System.ApplicationException
Agilent.N4010.EdrDriver.Exceptions.CannotConnectToInstrumentException

public class CannotConnectToInstrumentException : ApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Be aware of SCPI locking!

Requirements

Namespace: Agilent.N4010.EdrDriver.Exceptions

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

CannotConnectToInstrumentException Members | Agilent.N4010.EdrDriver.Exceptions Namespace


CannotConnectToInstrumentException Members

CannotConnectToInstrumentException overview

Public Instance Constructors

CannotConnectToInstrumentException Overloaded. Initializes a new instance of the CannotConnectToInstrumentException class.

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CannotConnectToInstrumentException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


CannotConnectToInstrumentException Constructor

Constructor for CannotConnectToInstrumentException, explanatory string provided

Overload List

Constructor for CannotConnectToInstrumentException, explanatory string provided

public CannotConnectToInstrumentException(string);

public CannotConnectToInstrumentException(string,Exception);

See Also

CannotConnectToInstrumentException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


CannotConnectToInstrumentException Constructor (String)

Constructor for CannotConnectToInstrumentException, explanatory string provided

public CannotConnectToInstrumentException(
string instrument
);

See Also

CannotConnectToInstrumentException Class | Agilent.N4010.EdrDriver.Exceptions Namespace | CannotConnectToInstrumentException Constructor Overload List


CannotConnectToInstrumentException Constructor (String, Exception)

public CannotConnectToInstrumentException(
string detail,
Exception innerException
);

See Also

CannotConnectToInstrumentException Class | Agilent.N4010.EdrDriver.Exceptions Namespace | CannotConnectToInstrumentException Constructor Overload List


ChannelFrequencyOutOfRangeException Class

Thrown when an attempt is made to set to a frequency outside the valid range.

For a list of all members of this type, see ChannelFrequencyOutOfRangeException Members.

System.Object
System.Exception
System.ApplicationException
Agilent.N4010.EdrDriver.Exceptions.InvalidParameterException
Agilent.N4010.EdrDriver.Exceptions.ChannelFrequencyOutOfRangeException

public class ChannelFrequencyOutOfRangeException : InvalidParameterException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The valid range for ChannelFrequency can be found in the definition of ChannelFrequency.

Requirements

Namespace: Agilent.N4010.EdrDriver.Exceptions

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

ChannelFrequencyOutOfRangeException Members | Agilent.N4010.EdrDriver.Exceptions Namespace


ChannelFrequencyOutOfRangeException Members

ChannelFrequencyOutOfRangeException overview

Public Instance Constructors

ChannelFrequencyOutOfRangeException Constructor Constructor for FrequencyOutOfRangeException, explanatory string provided

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ChannelFrequencyOutOfRangeException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


ChannelFrequencyOutOfRangeException Constructor

Constructor for FrequencyOutOfRangeException, explanatory string provided

public ChannelFrequencyOutOfRangeException(
string Detail
);

See Also

ChannelFrequencyOutOfRangeException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


EdrOutputLevelOutOfRangeException Class

Thrown when an attempt is made to set the Arbitrary Waveform Generator to a level outwith its valid range.

For a list of all members of this type, see EdrOutputLevelOutOfRangeException Members.

System.Object
System.Exception
System.ApplicationException
Agilent.N4010.EdrDriver.Exceptions.InvalidParameterException
Agilent.N4010.EdrDriver.Exceptions.EdrOutputLevelOutOfRangeException

public class EdrOutputLevelOutOfRangeException : InvalidParameterException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Agilent.N4010.EdrDriver.Exceptions

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

EdrOutputLevelOutOfRangeException Members | Agilent.N4010.EdrDriver.Exceptions Namespace


EdrOutputLevelOutOfRangeException Members

EdrOutputLevelOutOfRangeException overview

Public Instance Constructors

EdrOutputLevelOutOfRangeException Constructor Constructor for OutputLevelOutOfRangeException, explanatory string provided

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EdrOutputLevelOutOfRangeException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


EdrOutputLevelOutOfRangeException Constructor

Constructor for OutputLevelOutOfRangeException, explanatory string provided

public EdrOutputLevelOutOfRangeException(
string Detail
);

See Also

EdrOutputLevelOutOfRangeException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


ExpectedPacketTypeOutOfRangeException Class

Thrown when an attempt is made to set to the expected packet type outside the valid range.

For a list of all members of this type, see ExpectedPacketTypeOutOfRangeException Members.

System.Object
System.Exception
System.ApplicationException
Agilent.N4010.EdrDriver.Exceptions.InvalidParameterException
Agilent.N4010.EdrDriver.Exceptions.ExpectedPacketTypeOutOfRangeException

public class ExpectedPacketTypeOutOfRangeException : InvalidParameterException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The valid range for ExpectedPacketType can be found in the definition of ExpectedPacketType.

Requirements

Namespace: Agilent.N4010.EdrDriver.Exceptions

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

ExpectedPacketTypeOutOfRangeException Members | Agilent.N4010.EdrDriver.Exceptions Namespace


ExpectedPacketTypeOutOfRangeException Members

ExpectedPacketTypeOutOfRangeException overview

Public Instance Constructors

ExpectedPacketTypeOutOfRangeException Constructor Constructor for ExpectedPacketTypeOutOfRangeException, explanatory string provided

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExpectedPacketTypeOutOfRangeException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


ExpectedPacketTypeOutOfRangeException Constructor

Constructor for ExpectedPacketTypeOutOfRangeException, explanatory string provided

public ExpectedPacketTypeOutOfRangeException(
string Detail
);

See Also

ExpectedPacketTypeOutOfRangeException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


FailedToStartException Class

Thrown when starting a new instance of the Agilent.N4010.EdrDriver.Instrument class. Text may provide further information

For a list of all members of this type, see FailedToStartException Members.

System.Object
System.Exception
System.ApplicationException
Agilent.N4010.EdrDriver.Exceptions.FailedToStartException

public class FailedToStartException : ApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

-

Requirements

Namespace: Agilent.N4010.EdrDriver.Exceptions

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

FailedToStartException Members | Agilent.N4010.EdrDriver.Exceptions Namespace | Instrument


FailedToStartException Members

FailedToStartException overview

Public Instance Constructors

FailedToStartException Overloaded. Initializes a new instance of the FailedToStartException class.

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FailedToStartException Class | Agilent.N4010.EdrDriver.Exceptions Namespace | Instrument


FailedToStartException Constructor

Default constructor for FailedToStartException

Overload List

Default constructor for FailedToStartException

public FailedToStartException();

Constructor for FailedToStartException, explanatory string provided

public FailedToStartException(string);

Constructor for FailedToStartException, string and innerException provided.

public FailedToStartException(string,Exception);

See Also

FailedToStartException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


FailedToStartException Constructor ()

Default constructor for FailedToStartException

public FailedToStartException();

See Also

FailedToStartException Class | Agilent.N4010.EdrDriver.Exceptions Namespace | FailedToStartException Constructor Overload List


FailedToStartException Constructor (String)

Constructor for FailedToStartException, explanatory string provided

public FailedToStartException(
string detail
);

See Also

FailedToStartException Class | Agilent.N4010.EdrDriver.Exceptions Namespace | FailedToStartException Constructor Overload List


FailedToStartException Constructor (String, Exception)

Constructor for FailedToStartException, string and innerException provided.

public FailedToStartException(
string detail,
Exception innerException
);

See Also

FailedToStartException Class | Agilent.N4010.EdrDriver.Exceptions Namespace | FailedToStartException Constructor Overload List


FileStoreFullException Class

Thrown when an attempt is made to download a sequence or segment file or file set for which there is not enough free space.

For a list of all members of this type, see FileStoreFullException Members.

System.Object
System.Exception
System.ApplicationException
Agilent.N4010.EdrDriver.Exceptions.FileStoreFullException

public class FileStoreFullException : ApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Agilent.N4010.EdrDriver.Exceptions

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

FileStoreFullException Members | Agilent.N4010.EdrDriver.Exceptions Namespace


FileStoreFullException Members

FileStoreFullException overview

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
SpaceAvailable | Space available
SpaceRequired | Space required to store the file.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FileStoreFullException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


FileStoreFullException Properties

The properties of the FileStoreFullException class are listed below. For a complete list of FileStoreFullException class members, see the FileStoreFullException Members topic.

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
SpaceAvailable | Space available
SpaceRequired | Space required to store the file.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

FileStoreFullException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


SpaceAvailable Property

Agilent N4010A Bluetooth EDR Driver

FileStoreFullException.SpaceAvailable Property

Space available

public int SpaceAvailable {get;}

Remarks

This figure is the amount of space available in the appropriate filestore to which you were trying to download a file.

See Also

FileStoreFullException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


SpaceRequired Property

Agilent N4010A Bluetooth EDR Driver

FileStoreFullException.SpaceRequired Property

Space required to store the file.

public int SpaceRequired {get;}

Remarks

This figure is the amount of space required to store the file that you were trying to download.

See Also

FileStoreFullException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


FrequencyOutOfRangeException Class

Thrown when an attempt is made to set the output frequency outside the valid range.

For a list of all members of this type, see FrequencyOutOfRangeException Members.

System.Object
System.Exception
System.ApplicationException
Agilent.N4010.EdrDriver.Exceptions.InvalidParameterException
Agilent.N4010.EdrDriver.Exceptions.FrequencyOutOfRangeException

public class FrequencyOutOfRangeException : InvalidParameterException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The valid range for ChannelFrequencyOutput can be found in the definition of ChannelFrequencyOutput.

Requirements

Namespace: Agilent.N4010.EdrDriver.Exceptions

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

FrequencyOutOfRangeException Members | Agilent.N4010.EdrDriver.Exceptions Namespace


FrequencyOutOfRangeException Members

FrequencyOutOfRangeException overview

Public Instance Constructors

FrequencyOutOfRangeException Constructor Constructor for FrequencyOutOfRangeException, explanatory string provided

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FrequencyOutOfRangeException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


FrequencyOutOfRangeException Constructor

Constructor for FrequencyOutOfRangeException, explanatory string provided

public FrequencyOutOfRangeException(
string Detail
);

See Also

FrequencyOutOfRangeException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


IFBandwidthOutOfRangeException Class

Thrown when an attemps is made to set the IF bandwidth to an invalid value.

For a list of all members of this type, see IFBandwidthOutOfRangeException Members.

System.Object
System.Exception
System.ApplicationException
Agilent.N4010.EdrDriver.Exceptions.InvalidParameterException
Agilent.N4010.EdrDriver.Exceptions.IFBandwidthOutOfRangeException

public class IFBandwidthOutOfRangeException : InvalidParameterException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Agilent.N4010.EdrDriver.Exceptions

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

IFBandwidthOutOfRangeException Members | Agilent.N4010.EdrDriver.Exceptions Namespace


IFBandwidthOutOfRangeException Members

IFBandwidthOutOfRangeException overview

Public Instance Constructors

IFBandwidthOutOfRangeException Constructor Constructor for ReferenceLevelOutOfRangeException, explanatory string provided

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IFBandwidthOutOfRangeException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


IFBandwidthOutOfRangeException Constructor

Constructor for ReferenceLevelOutOfRangeException, explanatory string provided

public IFBandwidthOutOfRangeException(
string Detail
);

See Also

IFBandwidthOutOfRangeException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


InternalErrorException Class

Thrown when an public error occurs

For a list of all members of this type, see InternalErrorException Members.

System.Object
System.Exception
System.ApplicationException
Agilent.N4010.EdrDriver.Exceptions.InternalErrorException

public class InternalErrorException : ApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

-

Requirements

Namespace: Agilent.N4010.EdrDriver.Exceptions

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

InternalErrorException Members | Agilent.N4010.EdrDriver.Exceptions Namespace


InternalErrorException Members

InternalErrorException overview

Public Instance Constructors

InternalErrorException Overloaded. Initializes a new instance of the InternalErrorException class.

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InternalErrorException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


InternalErrorException Constructor

Constructor for InternalErrorException, explanatory string provided

Overload List

Constructor for InternalErrorException, explanatory string provided

public InternalErrorException(string);

Constructor for InternalErrorException, string and innerException provided.

public InternalErrorException(string,Exception);

See Also

InternalErrorException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


InternalErrorException Constructor (String)

Constructor for InternalErrorException, explanatory string provided

public InternalErrorException(
string detail
);

See Also

InternalErrorException Class | Agilent.N4010.EdrDriver.Exceptions Namespace | InternalErrorException Constructor Overload List


InternalErrorException Constructor (String, Exception)

Constructor for InternalErrorException, string and innerException provided.

public InternalErrorException(
string detail,
Exception innerException
);

See Also

InternalErrorException Class | Agilent.N4010.EdrDriver.Exceptions Namespace | InternalErrorException Constructor Overload List


InvalidFileNameException Class

Thrown when an attempt is made to load or save a file with an invalid name.

For a list of all members of this type, see InvalidFileNameException Members.

System.Object
System.Exception
System.ApplicationException
Agilent.N4010.EdrDriver.Exceptions.InvalidParameterException
Agilent.N4010.EdrDriver.Exceptions.InvalidFileNameException

public class InvalidFileNameException : InvalidParameterException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

There must be one segment file in any sequence file.

Requirements

Namespace: Agilent.N4010.EdrDriver.Exceptions

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

InvalidFileNameException Members | Agilent.N4010.EdrDriver.Exceptions Namespace


InvalidFileNameException Members

InvalidFileNameException overview

Public Instance Constructors

InvalidFileNameException Constructor

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InvalidFileNameException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


InvalidFileNameException Constructor

public InvalidFileNameException(
string FileName
);

See Also

InvalidFileNameException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


InvalidParameterException Class

Thrown when a call was made with an invalid parameter.

For a list of all members of this type, see InvalidParameterException Members.

System.Object
System.Exception
System.ApplicationException
Agilent.N4010.EdrDriver.Exceptions.InvalidParameterException
Derived types

public class InvalidParameterException : ApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

See the description of the function that was called for more information.

Requirements

Namespace: Agilent.N4010.EdrDriver.Exceptions

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

InvalidParameterException Members | Agilent.N4010.EdrDriver.Exceptions Namespace


InvalidParameterException Members

InvalidParameterException overview

Public Instance Constructors

InvalidParameterException Constructor Constructor for InvalidParameterException, explanatory string provided

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InvalidParameterException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


InvalidParameterException Constructor

Constructor for InvalidParameterException, explanatory string provided

public InvalidParameterException(
string detail
);

See Also

InvalidParameterException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


MeasurementErrorException Class

Thrown when the measurement returns an error.

For a list of all members of this type, see MeasurementErrorException Members.

System.Object
System.Exception
System.ApplicationException
Agilent.N4010.EdrDriver.Exceptions.MeasurementErrorException

public class MeasurementErrorException : ApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Agilent.N4010.EdrDriver.Exceptions

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

MeasurementErrorException Members | Agilent.N4010.EdrDriver.Exceptions Namespace


MeasurementErrorException Members

MeasurementErrorException overview

Public Instance Constructors

MeasurementErrorException Constructor Default constructor for MeasurementErrorException

Public Instance Properties

ExceptionMessage | Exception message information for measurement exceptions
ExceptionType | Exception type information for measurement exceptions
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MeasurementErrorException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


MeasurementErrorException Constructor

Default constructor for MeasurementErrorException

public MeasurementErrorException(
string measurement,
string exceptionType,
string exceptionMessage
);

See Also

MeasurementErrorException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


MeasurementErrorException Properties

The properties of the MeasurementErrorException class are listed below. For a complete list of MeasurementErrorException class members, see the MeasurementErrorException Members topic.

Public Instance Properties

ExceptionMessage | Exception message information for measurement exceptions
ExceptionType | Exception type information for measurement exceptions
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

MeasurementErrorException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


ExceptionMessage Property

Agilent N4010A Bluetooth EDR Driver

MeasurementErrorException.ExceptionMessage Property

Exception message information for measurement exceptions

public string ExceptionMessage {get;}

Property Value

The exact measurement error that occurred

Remarks

-

See Also

MeasurementErrorException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


ExceptionType Property

Agilent N4010A Bluetooth EDR Driver

MeasurementErrorException.ExceptionType Property

Exception type information for measurement exceptions

public string ExceptionType {get;}

Property Value

The type of measurement error that occurred

Remarks

-

See Also

MeasurementErrorException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


MeasurementRunningException Class

Thrown when you try to perform an operation, but a Measurement is already running on the N4010.

For a list of all members of this type, see MeasurementRunningException Members.

System.Object
System.Exception
System.ApplicationException
Agilent.N4010.EdrDriver.Exceptions.MeasurementRunningException

public class MeasurementRunningException : ApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

You can find out if a measurement is running from Instrument property MeasurementRunning

Requirements

Namespace: Agilent.N4010.EdrDriver.Exceptions

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

MeasurementRunningException Members | Agilent.N4010.EdrDriver.Exceptions Namespace


MeasurementRunningException Members

MeasurementRunningException overview

Public Instance Constructors

MeasurementRunningException Overloaded. Initializes a new instance of the MeasurementRunningException class.

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MeasurementRunningException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


MeasurementRunningException Constructor

Default constructor for MeasurementRunningException

Overload List

Default constructor for MeasurementRunningException

public MeasurementRunningException();

Constructor for MeasurementRunningException, explanatory string provided

public MeasurementRunningException(string);

Constructor for MeasurementRunningException, string and innerException provided.

public MeasurementRunningException(string,Exception);

See Also

MeasurementRunningException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


MeasurementRunningException Constructor ()

Default constructor for MeasurementRunningException

public MeasurementRunningException();

See Also

MeasurementRunningException Class | Agilent.N4010.EdrDriver.Exceptions Namespace | MeasurementRunningException Constructor Overload List


MeasurementRunningException Constructor (String)

Constructor for MeasurementRunningException, explanatory string provided

public MeasurementRunningException(
string detail
);

See Also

MeasurementRunningException Class | Agilent.N4010.EdrDriver.Exceptions Namespace | MeasurementRunningException Constructor Overload List


MeasurementRunningException Constructor (String, Exception)

Constructor for MeasurementRunningException, string and innerException provided.

public MeasurementRunningException(
string detail,
Exception innerException
);

See Also

MeasurementRunningException Class | Agilent.N4010.EdrDriver.Exceptions Namespace | MeasurementRunningException Constructor Overload List


MeasurementTimeoutException Class

Thrown when a measurement reports a timeout

For a list of all members of this type, see MeasurementTimeoutException Members.

System.Object
System.Exception
System.ApplicationException
Agilent.N4010.EdrDriver.Exceptions.MeasurementTimeoutException

public class MeasurementTimeoutException : ApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

The timeout cannot currently be set.

Requirements

Namespace: Agilent.N4010.EdrDriver.Exceptions

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

MeasurementTimeoutException Members | Agilent.N4010.EdrDriver.Exceptions Namespace


MeasurementTimeoutException Members

MeasurementTimeoutException overview

Public Instance Constructors

MeasurementTimeoutException Overloaded. Initializes a new instance of the MeasurementTimeoutException class.

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MeasurementTimeoutException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


MeasurementTimeoutException Constructor

Initializes a new instance of the MeasurementTimeoutException class.

Overload List

Initializes a new instance of the MeasurementTimeoutException class.

public MeasurementTimeoutException();

public MeasurementTimeoutException(string);

See Also

MeasurementTimeoutException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


MeasurementTimeoutException Constructor ()

Initializes a new instance of the MeasurementTimeoutException class.

public MeasurementTimeoutException();

See Also

MeasurementTimeoutException Class | Agilent.N4010.EdrDriver.Exceptions Namespace | MeasurementTimeoutException Constructor Overload List


MeasurementTimeoutException Constructor (String)

public MeasurementTimeoutException(
string detail
);

See Also

MeasurementTimeoutException Class | Agilent.N4010.EdrDriver.Exceptions Namespace | MeasurementTimeoutException Constructor Overload List


MeasurementTimeoutOutOfRangeException Class

Thrown when an attempt is made to set an invalid measurement timeout

For a list of all members of this type, see MeasurementTimeoutOutOfRangeException Members.

System.Object
System.Exception
System.ApplicationException
Agilent.N4010.EdrDriver.Exceptions.InvalidParameterException
Agilent.N4010.EdrDriver.Exceptions.MeasurementTimeoutOutOfRangeException

public class MeasurementTimeoutOutOfRangeException : InvalidParameterException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Agilent.N4010.EdrDriver.Exceptions

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

MeasurementTimeoutOutOfRangeException Members | Agilent.N4010.EdrDriver.Exceptions Namespace


MeasurementTimeoutOutOfRangeException Members

MeasurementTimeoutOutOfRangeException overview

Public Instance Constructors

MeasurementTimeoutOutOfRangeException Constructor Constructors for MeasurementTimeoutOutOfRangeException, explanatory string provided

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MeasurementTimeoutOutOfRangeException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


MeasurementTimeoutOutOfRangeException Constructor

Constructors for MeasurementTimeoutOutOfRangeException, explanatory string provided

public MeasurementTimeoutOutOfRangeException(
string detail
);

See Also

MeasurementTimeoutOutOfRangeException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


MissingSegmentFileException Class

Thrown when trying to select a sequence file that contains references to one or more segment files that do not exist on the instrument

For a list of all members of this type, see MissingSegmentFileException Members.

System.Object
System.Exception
System.ApplicationException
Agilent.N4010.EdrDriver.Exceptions.MissingSegmentFileException

public class MissingSegmentFileException : ApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

See SelectSequenceA and SelectSequenceB for more information.

Requirements

Namespace: Agilent.N4010.EdrDriver.Exceptions

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

MissingSegmentFileException Members | Agilent.N4010.EdrDriver.Exceptions Namespace


MissingSegmentFileException Members

MissingSegmentFileException overview

Public Instance Constructors

MissingSegmentFileException Constructor

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MissingSegmentFileException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


MissingSegmentFileException Constructor

public MissingSegmentFileException(
string SequenceFile
);

See Also

MissingSegmentFileException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


NoIQData Class

Thrown when trying to save IQ data when no IQ data has been received

For a list of all members of this type, see NoIQData Members.

System.Object
System.Exception
System.ApplicationException
Agilent.N4010.EdrDriver.Exceptions.NoIQData

public class NoIQData : ApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Agilent.N4010.EdrDriver.Exceptions

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

NoIQData Members | Agilent.N4010.EdrDriver.Exceptions Namespace


NoIQData Members

NoIQData overview

Public Instance Constructors

NoIQData Constructor

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NoIQData Class | Agilent.N4010.EdrDriver.Exceptions Namespace


NoIQData Constructor

public NoIQData(
string FileName
);

See Also

NoIQData Class | Agilent.N4010.EdrDriver.Exceptions Namespace


NoSequenceFileSelectedException Class

Thrown when an attempt is made to Trigger the AWG without a sequence file selected.

For a list of all members of this type, see NoSequenceFileSelectedException Members.

System.Object
System.Exception
System.ApplicationException
Agilent.N4010.EdrDriver.Exceptions.NoSequenceFileSelectedException

public class NoSequenceFileSelectedException : ApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

You must always select a sequence file using SelectSequenceA or SelectSequenceB before calling Trigger.

Requirements

Namespace: Agilent.N4010.EdrDriver.Exceptions

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

NoSequenceFileSelectedException Members | Agilent.N4010.EdrDriver.Exceptions Namespace


NoSequenceFileSelectedException Members

NoSequenceFileSelectedException overview

Public Instance Constructors

NoSequenceFileSelectedException Constructor Initializes a new instance of the NoSequenceFileSelectedException class.

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NoSequenceFileSelectedException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


NoSequenceFileSelectedException Constructor

Initializes a new instance of the NoSequenceFileSelectedException class.

public NoSequenceFileSelectedException();

See Also

NoSequenceFileSelectedException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


NoSuchInstrumentFileException Class

Thrown when trying to access a file where the name already does not exist on the hardware instrument.

For a list of all members of this type, see NoSuchInstrumentFileException Members.

System.Object
System.Exception
System.ApplicationException
Agilent.N4010.EdrDriver.Exceptions.NoSuchInstrumentFileException

public class NoSuchInstrumentFileException : ApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

See the description of the function that was called for more information.

Requirements

Namespace: Agilent.N4010.EdrDriver.Exceptions

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

NoSuchInstrumentFileException Members | Agilent.N4010.EdrDriver.Exceptions Namespace


NoSuchInstrumentFileException Members

NoSuchInstrumentFileException overview

Public Instance Constructors

NoSuchInstrumentFileException Constructor Constructor for NoSuchInstrumentFileException, explanatory string provided

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NoSuchInstrumentFileException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


NoSuchInstrumentFileException Constructor

Constructor for NoSuchInstrumentFileException, explanatory string provided

public NoSuchInstrumentFileException(
string File
);

See Also

NoSuchInstrumentFileException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


NotLicensedException Class

Thrown when an attempt is made to perform an operation that is not licensed

For a list of all members of this type, see NotLicensedException Members.

System.Object
System.Exception
System.ApplicationException
Agilent.N4010.EdrDriver.Exceptions.NotLicensedException

public class NotLicensedException : ApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Agilent.N4010.EdrDriver.Exceptions

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

NotLicensedException Members | Agilent.N4010.EdrDriver.Exceptions Namespace


NotLicensedException Members

NotLicensedException overview

Public Instance Constructors

NotLicensedException Overloaded. Initializes a new instance of the NotLicensedException class.

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NotLicensedException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


NotLicensedException Constructor

Default constructor for NoLicenseException

Overload List

Default constructor for NoLicenseException

public NotLicensedException(string);

public NotLicensedException(string,string,bool);

See Also

NotLicensedException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


NotLicensedException Constructor (String)

Default constructor for NoLicenseException

public NotLicensedException(
string Detail
);

See Also

NotLicensedException Class | Agilent.N4010.EdrDriver.Exceptions Namespace | NotLicensedException Constructor Overload List


NotLicensedException Constructor (String, String, Boolean)

public NotLicensedException(
string Detail,
string FieldName,
bool LicenseState
);

See Also

NotLicensedException Class | Agilent.N4010.EdrDriver.Exceptions Namespace | NotLicensedException Constructor Overload List


OutputLevelOutOfRangeException Class

Thrown when an attempt is made to set the Arbitrary Waveform Generator to a level outwith its valid range.

For a list of all members of this type, see OutputLevelOutOfRangeException Members.

System.Object
System.Exception
System.ApplicationException
Agilent.N4010.EdrDriver.Exceptions.InvalidParameterException
Agilent.N4010.EdrDriver.Exceptions.OutputLevelOutOfRangeException

public class OutputLevelOutOfRangeException : InvalidParameterException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Agilent.N4010.EdrDriver.Exceptions

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

OutputLevelOutOfRangeException Members | Agilent.N4010.EdrDriver.Exceptions Namespace


OutputLevelOutOfRangeException Members

OutputLevelOutOfRangeException overview

Public Instance Constructors

OutputLevelOutOfRangeException Constructor Constructor for OutputLevelOutOfRangeException, explanatory string provided

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OutputLevelOutOfRangeException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


OutputLevelOutOfRangeException Constructor

Constructor for OutputLevelOutOfRangeException, explanatory string provided

public OutputLevelOutOfRangeException(
string Detail
);

See Also

OutputLevelOutOfRangeException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


PacketNumberOutOfRangeException Class

Thrown when an attempt is made to set to the numbber of packets outside the valid range.

For a list of all members of this type, see PacketNumberOutOfRangeException Members.

System.Object
System.Exception
System.ApplicationException
Agilent.N4010.EdrDriver.Exceptions.InvalidParameterException
Agilent.N4010.EdrDriver.Exceptions.PacketNumberOutOfRangeException

public class PacketNumberOutOfRangeException : InvalidParameterException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Agilent.N4010.EdrDriver.Exceptions

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

PacketNumberOutOfRangeException Members | Agilent.N4010.EdrDriver.Exceptions Namespace


PacketNumberOutOfRangeException Members

PacketNumberOutOfRangeException overview

Public Instance Constructors

PacketNumberOutOfRangeException Constructor Default constructor for PowerRangeOutOfRangeException

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PacketNumberOutOfRangeException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


PacketNumberOutOfRangeException Constructor

Default constructor for PowerRangeOutOfRangeException

public PacketNumberOutOfRangeException(
string Detail
);

See Also

PacketNumberOutOfRangeException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


PowerLevelOutOfRangeException Class

Thrown when an attempt is made to set to a power range outside the valid range.

For a list of all members of this type, see PowerLevelOutOfRangeException Members.

System.Object
System.Exception
System.ApplicationException
Agilent.N4010.EdrDriver.Exceptions.InvalidParameterException
Agilent.N4010.EdrDriver.Exceptions.PowerLevelOutOfRangeException

public class PowerLevelOutOfRangeException : InvalidParameterException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Agilent.N4010.EdrDriver.Exceptions

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

PowerLevelOutOfRangeException Members | Agilent.N4010.EdrDriver.Exceptions Namespace


PowerLevelOutOfRangeException Members

PowerLevelOutOfRangeException overview

Public Instance Constructors

PowerLevelOutOfRangeException Constructor Default constructor for PowerRangeOutOfRangeException

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PowerLevelOutOfRangeException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


PowerLevelOutOfRangeException Constructor

Default constructor for PowerRangeOutOfRangeException

public PowerLevelOutOfRangeException(
string Detail
);

See Also

PowerLevelOutOfRangeException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


ResultNotAvailableException Class

Thrown when a query is made for a measurement result but no result is available

For a list of all members of this type, see ResultNotAvailableException Members.

System.Object
System.Exception
System.ApplicationException
Agilent.N4010.EdrDriver.Exceptions.ResultNotAvailableException

public class ResultNotAvailableException : ApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Agilent.N4010.EdrDriver.Exceptions

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

ResultNotAvailableException Members | Agilent.N4010.EdrDriver.Exceptions Namespace


ResultNotAvailableException Members

ResultNotAvailableException overview

Public Instance Constructors

ResultNotAvailableException Overloaded. Initializes a new instance of the ResultNotAvailableException class.

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResultNotAvailableException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


ResultNotAvailableException Constructor

Default constructor for ResultNotAvailableException

Overload List

Default constructor for ResultNotAvailableException

public ResultNotAvailableException();

Constructor for ResultNotAvailableException, explanatory string provided

public ResultNotAvailableException(string);

Constructor for ResultNotAvailableException, string and innerException provided.

public ResultNotAvailableException(string,Exception);

See Also

ResultNotAvailableException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


ResultNotAvailableException Constructor ()

Default constructor for ResultNotAvailableException

public ResultNotAvailableException();

See Also

ResultNotAvailableException Class | Agilent.N4010.EdrDriver.Exceptions Namespace | ResultNotAvailableException Constructor Overload List


ResultNotAvailableException Constructor (String)

Constructor for ResultNotAvailableException, explanatory string provided

public ResultNotAvailableException(
string detail
);

See Also

ResultNotAvailableException Class | Agilent.N4010.EdrDriver.Exceptions Namespace | ResultNotAvailableException Constructor Overload List


ResultNotAvailableException Constructor (String, Exception)

Constructor for ResultNotAvailableException, string and innerException provided.

public ResultNotAvailableException(
string detail,
Exception innerException
);

See Also

ResultNotAvailableException Class | Agilent.N4010.EdrDriver.Exceptions Namespace | ResultNotAvailableException Constructor Overload List


SourceActiveException Class

Thrown when you try to perform an operation, but the source is already running on the N4010.

For a list of all members of this type, see SourceActiveException Members.

System.Object
System.Exception
System.ApplicationException
Agilent.N4010.EdrDriver.Exceptions.SourceActiveException

public class SourceActiveException : ApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Agilent.N4010.EdrDriver.Exceptions

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

SourceActiveException Members | Agilent.N4010.EdrDriver.Exceptions Namespace


SourceActiveException Members

SourceActiveException overview

Public Instance Constructors

SourceActiveException Overloaded. Initializes a new instance of the SourceActiveException class.

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SourceActiveException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


SourceActiveException Constructor

Default constructor for SourceActiveException

Overload List

Default constructor for SourceActiveException

public SourceActiveException();

Constructor for SourceActiveException, explanatory string provided

public SourceActiveException(string);

Constructor for SourceActiveException, string and innerException provided.

public SourceActiveException(string,Exception);

See Also

SourceActiveException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


SourceActiveException Constructor ()

Default constructor for SourceActiveException

public SourceActiveException();

See Also

SourceActiveException Class | Agilent.N4010.EdrDriver.Exceptions Namespace | SourceActiveException Constructor Overload List


SourceActiveException Constructor (String)

Constructor for SourceActiveException, explanatory string provided

public SourceActiveException(
string detail
);

See Also

SourceActiveException Class | Agilent.N4010.EdrDriver.Exceptions Namespace | SourceActiveException Constructor Overload List


SourceActiveException Constructor (String, Exception)

Constructor for SourceActiveException, string and innerException provided.

public SourceActiveException(
string detail,
Exception innerException
);

See Also

SourceActiveException Class | Agilent.N4010.EdrDriver.Exceptions Namespace | SourceActiveException Constructor Overload List


SourceInactiveException Class

Thrown when you try to perform an operation, but the source is not currently running on the N4010.

For a list of all members of this type, see SourceInactiveException Members.

System.Object
System.Exception
System.ApplicationException
Agilent.N4010.EdrDriver.Exceptions.SourceInactiveException

public class SourceInactiveException : ApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Agilent.N4010.EdrDriver.Exceptions

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

SourceInactiveException Members | Agilent.N4010.EdrDriver.Exceptions Namespace


SourceInactiveException Members

SourceInactiveException overview

Public Instance Constructors

SourceInactiveException Overloaded. Initializes a new instance of the SourceInactiveException class.

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SourceInactiveException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


SourceInactiveException Constructor

Default constructor for SourceInactiveException

Overload List

Default constructor for SourceInactiveException

public SourceInactiveException();

Constructor for SourceInactiveException, explanatory string provided

public SourceInactiveException(string);

Constructor for SourceInactiveException, string and innerException provided.

public SourceInactiveException(string,Exception);

See Also

SourceInactiveException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


SourceInactiveException Constructor ()

Default constructor for SourceInactiveException

public SourceInactiveException();

See Also

SourceInactiveException Class | Agilent.N4010.EdrDriver.Exceptions Namespace | SourceInactiveException Constructor Overload List


SourceInactiveException Constructor (String)

Constructor for SourceInactiveException, explanatory string provided

public SourceInactiveException(
string detail
);

See Also

SourceInactiveException Class | Agilent.N4010.EdrDriver.Exceptions Namespace | SourceInactiveException Constructor Overload List


SourceInactiveException Constructor (String, Exception)

Constructor for SourceInactiveException, string and innerException provided.

public SourceInactiveException(
string detail,
Exception innerException
);

See Also

SourceInactiveException Class | Agilent.N4010.EdrDriver.Exceptions Namespace | SourceInactiveException Constructor Overload List


TriggerIdleOutOfRangeException Class

Thrown when an attempt is made to set Trigger Idle outside the valid range.

For a list of all members of this type, see TriggerIdleOutOfRangeException Members.

System.Object
System.Exception
System.ApplicationException
Agilent.N4010.EdrDriver.Exceptions.InvalidParameterException
Agilent.N4010.EdrDriver.Exceptions.TriggerIdleOutOfRangeException

public class TriggerIdleOutOfRangeException : InvalidParameterException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

-

Requirements

Namespace: Agilent.N4010.EdrDriver.Exceptions

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

TriggerIdleOutOfRangeException Members | Agilent.N4010.EdrDriver.Exceptions Namespace


TriggerIdleOutOfRangeException Members

TriggerIdleOutOfRangeException overview

Public Instance Constructors

TriggerIdleOutOfRangeException Constructor Constructor for TriggerIdleOutOfRangeException, explanatory string provided

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TriggerIdleOutOfRangeException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


TriggerIdleOutOfRangeException Constructor

Constructor for TriggerIdleOutOfRangeException, explanatory string provided

public TriggerIdleOutOfRangeException(
string Detail
);

See Also

TriggerIdleOutOfRangeException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


TriggerLevelOutOfRangeException Class

Thrown when an attempt is made to set to a trigger level outside the valid range.

For a list of all members of this type, see TriggerLevelOutOfRangeException Members.

System.Object
System.Exception
System.ApplicationException
Agilent.N4010.EdrDriver.Exceptions.InvalidParameterException
Agilent.N4010.EdrDriver.Exceptions.TriggerLevelOutOfRangeException

public class TriggerLevelOutOfRangeException : InvalidParameterException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Agilent.N4010.EdrDriver.Exceptions

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

TriggerLevelOutOfRangeException Members | Agilent.N4010.EdrDriver.Exceptions Namespace


TriggerLevelOutOfRangeException Members

TriggerLevelOutOfRangeException overview

Public Instance Constructors

TriggerLevelOutOfRangeException Constructor Constructor for TriggerLevelOutOfRangeException, explanatory string provided

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TriggerLevelOutOfRangeException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


TriggerLevelOutOfRangeException Constructor

Constructor for TriggerLevelOutOfRangeException, explanatory string provided

public TriggerLevelOutOfRangeException(
string Detail
);

See Also

TriggerLevelOutOfRangeException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


TriggerSlopeOutOfRangeException Class

Thrown when an attempt is made to set Trigger Slope outside the valid range.

For a list of all members of this type, see TriggerSlopeOutOfRangeException Members.

System.Object
System.Exception
System.ApplicationException
Agilent.N4010.EdrDriver.Exceptions.InvalidParameterException
Agilent.N4010.EdrDriver.Exceptions.TriggerSlopeOutOfRangeException

public class TriggerSlopeOutOfRangeException : InvalidParameterException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

-

Requirements

Namespace: Agilent.N4010.EdrDriver.Exceptions

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

TriggerSlopeOutOfRangeException Members | Agilent.N4010.EdrDriver.Exceptions Namespace


TriggerSlopeOutOfRangeException Members

TriggerSlopeOutOfRangeException overview

Public Instance Constructors

TriggerSlopeOutOfRangeException Constructor Constructor for TriggerStyleOutOfRangeException, explanatory string provided

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TriggerSlopeOutOfRangeException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


TriggerSlopeOutOfRangeException Constructor

Constructor for TriggerStyleOutOfRangeException, explanatory string provided

public TriggerSlopeOutOfRangeException(
string Detail
);

See Also

TriggerSlopeOutOfRangeException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


TriggerStyleOutOfRangeException Class

Thrown when an attempt is made to set Trigger Style outside the valid range.

For a list of all members of this type, see TriggerStyleOutOfRangeException Members.

System.Object
System.Exception
System.ApplicationException
Agilent.N4010.EdrDriver.Exceptions.InvalidParameterException
Agilent.N4010.EdrDriver.Exceptions.TriggerStyleOutOfRangeException

public class TriggerStyleOutOfRangeException : InvalidParameterException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

-

Requirements

Namespace: Agilent.N4010.EdrDriver.Exceptions

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

TriggerStyleOutOfRangeException Members | Agilent.N4010.EdrDriver.Exceptions Namespace


TriggerStyleOutOfRangeException Members

TriggerStyleOutOfRangeException overview

Public Instance Constructors

TriggerStyleOutOfRangeException Constructor Constructor for TriggerStyleOutOfRangeException, explanatory string provided

Public Instance Properties

HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TriggerStyleOutOfRangeException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


TriggerStyleOutOfRangeException Constructor

Constructor for TriggerStyleOutOfRangeException, explanatory string provided

public TriggerStyleOutOfRangeException(
string Detail
);

See Also

TriggerStyleOutOfRangeException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


VisaException Class

Thrown when an error is reported by the VISA subsystem

For a list of all members of this type, see VisaException Members.

System.Object
System.Exception
System.ApplicationException
Agilent.N4010.EdrDriver.Exceptions.VisaException

public class VisaException : ApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

See the description of the function that was called for more information.

Requirements

Namespace: Agilent.N4010.EdrDriver.Exceptions

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

VisaException Members | Agilent.N4010.EdrDriver.Exceptions Namespace


VisaException Members

VisaException overview

Public Instance Constructors

VisaException Overloaded. Initializes a new instance of the VisaException class.

Public Instance Properties

ErrorCode | Error code returned by the VISA subsystem
ErrorName | Textual representation of the error returned by the VISA subsystem
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

VisaException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


VisaException Constructor

Constructor for VisaException, explanatory string provided

Overload List

Constructor for VisaException, explanatory string provided

public VisaException(string);

public VisaException(string,string);

See Also

VisaException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


VisaException Constructor (String)

Constructor for VisaException, explanatory string provided

public VisaException(
string Error
);

See Also

VisaException Class | Agilent.N4010.EdrDriver.Exceptions Namespace | VisaException Constructor Overload List


VisaException Constructor (String, String)

public VisaException(
string Error,
string Value
);

See Also

VisaException Class | Agilent.N4010.EdrDriver.Exceptions Namespace | VisaException Constructor Overload List


VisaException Properties

The properties of the VisaException class are listed below. For a complete list of VisaException class members, see the VisaException Members topic.

Public Instance Properties

ErrorCode | Error code returned by the VISA subsystem
ErrorName | Textual representation of the error returned by the VISA subsystem
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

VisaException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


ErrorCode Property

Agilent N4010A Bluetooth EDR Driver

VisaException.ErrorCode Property

Error code returned by the VISA subsystem

public int ErrorCode {get;}

Property Value

Numeric error code returned from VISA subsystem

See Also

VisaException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


ErrorName Property

Agilent N4010A Bluetooth EDR Driver

VisaException.ErrorName Property

Textual representation of the error returned by the VISA subsystem

public string ErrorName {get;}

Property Value

Textual representation of the error returned by the VISA subsystem

See Also

VisaException Class | Agilent.N4010.EdrDriver.Exceptions Namespace


Agilent.N4010.EdrDriver.Generator

Agilent N4010A Bluetooth EDR Driver

Agilent.N4010.EdrDriver.Generator Namespace

Namespace hierarchy

Classes

Class | Description
Generator | The Generator object "plays" Bluetooth EDR waveforms over the instrument's RF port. These waveforms are used to stimulate the Device Under Test, allowing the DUT's response to the stimulus to be measured.


Generator Class

The Generator object "plays" Bluetooth EDR waveforms over the instrument's RF port. These waveforms are used to stimulate the Device Under Test, allowing the DUT's response to the stimulus to be measured.

For a list of all members of this type, see Generator Members.

System.Object
Agilent.N4010.EdrDriver.Generator.Generator

public class Generator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Agilent.N4010.EdrDriver.Generator

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

Generator Members | Agilent.N4010.EdrDriver.Generator Namespace


Generator Members

Generator overview

Public Instance Properties

ChannelFrequencyOuput
Level
PacketType
TxImpairments

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadCustomFile | Load a custom made segment file to the instrument.
Start | Start the transmission of the selected packet type.
Stop | Stop transmission of the packet.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Generator Class | Agilent.N4010.EdrDriver.Generator Namespace


Generator Properties

The properties of the Generator class are listed below. For a complete list of Generator class members, see the Generator Members topic.

Public Instance Properties

ChannelFrequencyOuput
Level
PacketType
TxImpairments

See Also

Generator Class | Agilent.N4010.EdrDriver.Generator Namespace


ChannelFrequencyOuput Property

Agilent N4010A Bluetooth EDR Driver

Generator.ChannelFrequencyOuput Property

public double ChannelFrequencyOuput {get; set;}

See Also

Generator Class | Agilent.N4010.EdrDriver.Generator Namespace


Level Property

Agilent N4010A Bluetooth EDR Driver

Generator.Level Property

public double Level {get; set;}

See Also

Generator Class | Agilent.N4010.EdrDriver.Generator Namespace


PacketType Property

Agilent N4010A Bluetooth EDR Driver

Generator.PacketType Property

public Agilent.N4010.EdrDriver.Enums.TransmitPacketType PacketType {get; set;}

See Also

Generator Class | Agilent.N4010.EdrDriver.Generator Namespace


TxImpairments Property

Agilent N4010A Bluetooth EDR Driver

Generator.TxImpairments Property

public bool TxImpairments {get; set;}

See Also

Generator Class | Agilent.N4010.EdrDriver.Generator Namespace


Generator Methods

The methods of the Generator class are listed below. For a complete list of Generator class members, see the Generator Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
LoadCustomFile | Load a custom made segment file to the instrument.
Start | Start the transmission of the selected packet type.
Stop | Stop transmission of the packet.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Generator Class | Agilent.N4010.EdrDriver.Generator Namespace


Generator.LoadCustomFile Method

Load a custom made segment file to the instrument.

public void LoadCustomFile(
string windowsFilename
);

Parameters

windowsFilename
The name and path of the segment file to be loaded.

See Also

Generator Class | Agilent.N4010.EdrDriver.Generator Namespace


Generator.Start Method

Start the transmission of the selected packet type.

public void Start();

See Also

Generator Class | Agilent.N4010.EdrDriver.Generator Namespace


Generator.Stop Method

Stop transmission of the packet.

public void Stop();

See Also

Generator Class | Agilent.N4010.EdrDriver.Generator Namespace


Agilent.N4010.EdrDriver.Measurements

Agilent N4010A Bluetooth EDR Driver

Agilent.N4010.EdrDriver.Measurements Namespace

Namespace hierarchy

Classes

Class | Description
BasebandIq | Result Baseband IQ measured by the instrument.
CarrierStabilityModulationAccuracy | Class to run and return values for the Carrier Stability and Modulation Accuracy test.
DataMarkers | Class to return values for markers calculated during an EDR test.
DifferentialPhaseEncoding | Class to run and return values for the Differential Phase Encoding test.
MeasurementBaseFrontEnd | Base class inherited by all measurement objects.
MeasurementSetup | The measurement parameters needed to set up a measurement
Power | Class to sample the generic power of input data
RelativePower | Average Power for both the GFSK and DPSK part of the measurement.


BasebandIq Class

Result
Baseband IQ measured by the instrument.

For a list of all members of this type, see BasebandIq Members.

System.Object
Agilent.N4010.EdrDriver.Measurements.MeasurementBaseFrontEnd
Agilent.N4010.EdrDriver.Measurements.BasebandIq

public class BasebandIq : MeasurementBaseFrontEnd

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This measurement is a format independant measurement which runs independant of the modulation format.

Requirements

Namespace: Agilent.N4010.EdrDriver.Measurements

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

BasebandIq Members | Agilent.N4010.EdrDriver.Measurements Namespace


BasebandIq Members

BasebandIq overview

Public Instance Properties

MeasurementSuccess (inherited from MeasurementBaseFrontEnd)
Results
Settings

Public Instance Methods

CalcResults (inherited from MeasurementBaseFrontEnd) | Calculate the results based on the sampled iq and p0 bit already stored in Basebandiq and DataMarker results.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run (inherited from MeasurementBaseFrontEnd) | Run the measurement.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BasebandIq Class | Agilent.N4010.EdrDriver.Measurements Namespace


BasebandIq Properties

The properties of the BasebandIq class are listed below. For a complete list of BasebandIq class members, see the BasebandIq Members topic.

Public Instance Properties

MeasurementSuccess (inherited from MeasurementBaseFrontEnd)
Results
Settings

See Also

BasebandIq Class | Agilent.N4010.EdrDriver.Measurements Namespace


Results Property

Agilent N4010A Bluetooth EDR Driver

BasebandIq.Results Property

public Results.tBasebandIqResults Results {get;}

See Also

BasebandIq Class | Agilent.N4010.EdrDriver.Measurements Namespace


Settings Property

Agilent N4010A Bluetooth EDR Driver

BasebandIq.Settings Property

public Settings.tBasebandIqSettings Settings {get; set;}

See Also

BasebandIq Class | Agilent.N4010.EdrDriver.Measurements Namespace


CarrierStabilityModulationAccuracy Class

Class to run and return values for the Carrier Stability and Modulation Accuracy test.

For a list of all members of this type, see CarrierStabilityModulationAccuracy Members.

System.Object
Agilent.N4010.EdrDriver.Measurements.MeasurementBaseFrontEnd
Agilent.N4010.EdrDriver.Measurements.CarrierStabilityModulationAccuracy

public class CarrierStabilityModulationAccuracy : MeasurementBaseFrontEnd

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Agilent.N4010.EdrDriver.Measurements

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

CarrierStabilityModulationAccuracy Members | Agilent.N4010.EdrDriver.Measurements Namespace


CarrierStabilityModulationAccuracy Members

CarrierStabilityModulationAccuracy overview

Public Instance Properties

MeasurementSuccess (inherited from MeasurementBaseFrontEnd) |
Results | The output results for the measurement
Settings | The input settings for the measurement

Public Instance Methods

CalcResults (inherited from MeasurementBaseFrontEnd) | Calculate the results based on the sampled iq and p0 bit already stored in Basebandiq and DataMarker results.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Run the Carrier Frequency Stability and Modulation Accuracy measurement.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CarrierStabilityModulationAccuracy Class | Agilent.N4010.EdrDriver.Measurements Namespace


CarrierStabilityModulationAccuracy Properties

The properties of the CarrierStabilityModulationAccuracy class are listed below. For a complete list of CarrierStabilityModulationAccuracy class members, see the CarrierStabilityModulationAccuracy Members topic.

Public Instance Properties

MeasurementSuccess (inherited from MeasurementBaseFrontEnd) |
Results | The output results for the measurement
Settings | The input settings for the measurement

See Also

CarrierStabilityModulationAccuracy Class | Agilent.N4010.EdrDriver.Measurements Namespace


Results Property

Agilent N4010A Bluetooth EDR Driver

CarrierStabilityModulationAccuracy.Results Property

The output results for the measurement

public Results.tCarrierStabilityModulationAccuracyResults Results {get;}

See Also

CarrierStabilityModulationAccuracy Class | Agilent.N4010.EdrDriver.Measurements Namespace


Settings Property

Agilent N4010A Bluetooth EDR Driver

CarrierStabilityModulationAccuracy.Settings Property

The input settings for the measurement

public Settings.tCarrierStabilityModulationAccuracySettings Settings {get; set;}

See Also

CarrierStabilityModulationAccuracy Class | Agilent.N4010.EdrDriver.Measurements Namespace


CarrierStabilityModulationAccuracy Methods

The methods of the CarrierStabilityModulationAccuracy class are listed below. For a complete list of CarrierStabilityModulationAccuracy class members, see the CarrierStabilityModulationAccuracy Members topic.

Public Instance Methods

CalcResults (inherited from MeasurementBaseFrontEnd) | Calculate the results based on the sampled iq and p0 bit already stored in Basebandiq and DataMarker results.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Run the Carrier Frequency Stability and Modulation Accuracy measurement.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CarrierStabilityModulationAccuracy Class | Agilent.N4010.EdrDriver.Measurements Namespace


CarrierStabilityModulationAccuracy.Run Method

Run the Carrier Frequency Stability and Modulation Accuracy measurement.

public override void Run();

See Also

CarrierStabilityModulationAccuracy Class | Agilent.N4010.EdrDriver.Measurements Namespace


DataMarkers Class

Class to return values for markers calculated during an EDR test.

For a list of all members of this type, see DataMarkers Members.

System.Object
Agilent.N4010.EdrDriver.Measurements.DataMarkers

public class DataMarkers

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Agilent.N4010.EdrDriver.Measurements

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

DataMarkers Members | Agilent.N4010.EdrDriver.Measurements Namespace


DataMarkers Members

DataMarkers overview

Public Instance Properties

Results The input parameter setting for the Differential Phase Encoding test.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataMarkers Class | Agilent.N4010.EdrDriver.Measurements Namespace


DataMarkers Properties

The properties of the DataMarkers class are listed below. For a complete list of DataMarkers class members, see the DataMarkers Members topic.

Public Instance Properties

Results The input parameter setting for the Differential Phase Encoding test.

See Also

DataMarkers Class | Agilent.N4010.EdrDriver.Measurements Namespace


Results Property

Agilent N4010A Bluetooth EDR Driver

DataMarkers.Results Property

The input parameter setting for the Differential Phase Encoding test.

public Results.tDataMarkersResults Results {get; set;}

See Also

DataMarkers Class | Agilent.N4010.EdrDriver.Measurements Namespace


DifferentialPhaseEncoding Class

Class to run and return values for the Differential Phase Encoding test.

For a list of all members of this type, see DifferentialPhaseEncoding Members.

System.Object
Agilent.N4010.EdrDriver.Measurements.MeasurementBaseFrontEnd
Agilent.N4010.EdrDriver.Measurements.DifferentialPhaseEncoding

public class DifferentialPhaseEncoding : MeasurementBaseFrontEnd

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Agilent.N4010.EdrDriver.Measurements

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

DifferentialPhaseEncoding Members | Agilent.N4010.EdrDriver.Measurements Namespace


DifferentialPhaseEncoding Members

DifferentialPhaseEncoding overview

Public Instance Properties

MeasurementSuccess (inherited from MeasurementBaseFrontEnd) |
Results | The input parameter setting for the Differential Phase Encoding test.
Settings | The input parameter setting for the Differential Phase Encoding test.

Public Instance Methods

CalcResults (inherited from MeasurementBaseFrontEnd) | Calculate the results based on the sampled iq and p0 bit already stored in Basebandiq and DataMarker results.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Run the Differential Phase Encoding measurement.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DifferentialPhaseEncoding Class | Agilent.N4010.EdrDriver.Measurements Namespace


DifferentialPhaseEncoding Properties

The properties of the DifferentialPhaseEncoding class are listed below. For a complete list of DifferentialPhaseEncoding class members, see the DifferentialPhaseEncoding Members topic.

Public Instance Properties

MeasurementSuccess (inherited from MeasurementBaseFrontEnd) |
Results | The input parameter setting for the Differential Phase Encoding test.
Settings | The input parameter setting for the Differential Phase Encoding test.

See Also

DifferentialPhaseEncoding Class | Agilent.N4010.EdrDriver.Measurements Namespace


Results Property

Agilent N4010A Bluetooth EDR Driver

DifferentialPhaseEncoding.Results Property

The input parameter setting for the Differential Phase Encoding test.

public Results.tDifferentialPhaseEncodingResults Results {get; set;}

See Also

DifferentialPhaseEncoding Class | Agilent.N4010.EdrDriver.Measurements Namespace


Settings Property

Agilent N4010A Bluetooth EDR Driver

DifferentialPhaseEncoding.Settings Property

The input parameter setting for the Differential Phase Encoding test.

public Settings.tDifferentialPhaseEncodingSettings Settings {get; set;}

See Also

DifferentialPhaseEncoding Class | Agilent.N4010.EdrDriver.Measurements Namespace


DifferentialPhaseEncoding Methods

The methods of the DifferentialPhaseEncoding class are listed below. For a complete list of DifferentialPhaseEncoding class members, see the DifferentialPhaseEncoding Members topic.

Public Instance Methods

CalcResults (inherited from MeasurementBaseFrontEnd) | Calculate the results based on the sampled iq and p0 bit already stored in Basebandiq and DataMarker results.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Run the Differential Phase Encoding measurement.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DifferentialPhaseEncoding Class | Agilent.N4010.EdrDriver.Measurements Namespace


DifferentialPhaseEncoding.Run Method

Run the Differential Phase Encoding measurement.

public override void Run();

See Also

DifferentialPhaseEncoding Class | Agilent.N4010.EdrDriver.Measurements Namespace


MeasurementBaseFrontEnd Class

Base class inherited by all measurement objects.

For a list of all members of this type, see MeasurementBaseFrontEnd Members.

System.Object
Agilent.N4010.EdrDriver.Measurements.MeasurementBaseFrontEnd
Agilent.N4010.EdrDriver.Measurements.BasebandIq
Agilent.N4010.EdrDriver.Measurements.CarrierStabilityModulationAccuracy
Agilent.N4010.EdrDriver.Measurements.DifferentialPhaseEncoding
Agilent.N4010.EdrDriver.Measurements.Power
Agilent.N4010.EdrDriver.Measurements.RelativePower

public abstract class MeasurementBaseFrontEnd

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

-

Requirements

Namespace: Agilent.N4010.EdrDriver.Measurements

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

MeasurementBaseFrontEnd Members | Agilent.N4010.EdrDriver.Measurements Namespace


MeasurementBaseFrontEnd Members

MeasurementBaseFrontEnd overview

Public Instance Properties

MeasurementSuccess

Public Instance Methods

CalcResults | Calculate the results based on the sampled iq and p0 bit already stored in Basebandiq and DataMarker results.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Run the measurement.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MeasurementBaseFrontEnd Class | Agilent.N4010.EdrDriver.Measurements Namespace


MeasurementBaseFrontEnd Properties

The properties of the MeasurementBaseFrontEnd class are listed below. For a complete list of MeasurementBaseFrontEnd class members, see the MeasurementBaseFrontEnd Members topic.

Public Instance Properties

MeasurementSuccess

See Also

MeasurementBaseFrontEnd Class | Agilent.N4010.EdrDriver.Measurements Namespace


MeasurementSuccess Property

Agilent N4010A Bluetooth EDR Driver

MeasurementBaseFrontEnd.MeasurementSuccess Property

public bool MeasurementSuccess {get;}

See Also

MeasurementBaseFrontEnd Class | Agilent.N4010.EdrDriver.Measurements Namespace


MeasurementBaseFrontEnd Methods

The methods of the MeasurementBaseFrontEnd class are listed below. For a complete list of MeasurementBaseFrontEnd class members, see the MeasurementBaseFrontEnd Members topic.

Public Instance Methods

CalcResults | Calculate the results based on the sampled iq and p0 bit already stored in Basebandiq and DataMarker results.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run | Run the measurement.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MeasurementBaseFrontEnd Class | Agilent.N4010.EdrDriver.Measurements Namespace


MeasurementBaseFrontEnd.CalcResults Method

Calculate the results based on the sampled iq and p0 bit already stored in Basebandiq and DataMarker results.

public virtual void CalcResults();

See Also

MeasurementBaseFrontEnd Class | Agilent.N4010.EdrDriver.Measurements Namespace


MeasurementBaseFrontEnd.Run Method

Run the measurement.

public virtual void Run();

See Also

MeasurementBaseFrontEnd Class | Agilent.N4010.EdrDriver.Measurements Namespace


MeasurementSetup Class

The measurement parameters needed to set up a measurement

For a list of all members of this type, see MeasurementSetup Members.

System.Object
Agilent.N4010.EdrDriver.Measurements.MeasurementSetup

public class MeasurementSetup

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This measurement is a format independant measurement which runs independant of the modulation format.

Requirements

Namespace: Agilent.N4010.EdrDriver.Measurements

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

MeasurementSetup Members | Agilent.N4010.EdrDriver.Measurements Namespace


MeasurementSetup Members

MeasurementSetup overview

Public Instance Properties

AcquisitionOffsetTime | Time between the trigger and the point where measurement starts
AcquisitionTime | Sets the maximum acquisition time to capture a packet to do EDR measurements on.
ChannelFrequency | Measurement frequency.
ExpectedPacketType | Expected packet type.
IFBandwidth | Instrument IF Bandwidth
PowerRange | Input power range.
TriggerIdle | Trigger Idle
TriggerLevel | Trigger Level
TriggerSlope | Trigger Slope
TriggerStyle | Trigger Style

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MeasurementSetup Class | Agilent.N4010.EdrDriver.Measurements Namespace


MeasurementSetup Properties

The properties of the MeasurementSetup class are listed below. For a complete list of MeasurementSetup class members, see the MeasurementSetup Members topic.

Public Instance Properties

AcquisitionOffsetTime | Time between the trigger and the point where measurement starts
AcquisitionTime | Sets the maximum acquisition time to capture a packet to do EDR measurements on.
ChannelFrequency | Measurement frequency.
ExpectedPacketType | Expected packet type.
IFBandwidth | Instrument IF Bandwidth
PowerRange | Input power range.
TriggerIdle | Trigger Idle
TriggerLevel | Trigger Level
TriggerSlope | Trigger Slope
TriggerStyle | Trigger Style

See Also

MeasurementSetup Class | Agilent.N4010.EdrDriver.Measurements Namespace


AcquisitionOffsetTime Property

Agilent N4010A Bluetooth EDR Driver

MeasurementSetup.AcquisitionOffsetTime Property

Time between the trigger and the point where measurement starts

public double AcquisitionOffsetTime {get; set;}

Property Value

Unit | seconds
Default | 0
Minimum | -4.58752e-3 (-4.58752ms)
Maximum | 5.24288e-3 (5.24288ms)
Resolution | 10e-3 (10ns)

Remarks

Cannot be set while a measurement is running, a calibration or self test is in progress, or the source is running.

Exceptions

Exception Type | Condition
AcquisitionOffsetTimeOutOfRangeException | Invalid value provided
MeasurementRunningException | A measurement is currently running. You can find out if a measurement is running by reading the MeasurementRunning property.
SourceActiveException | The source is currently running or a sequence file is selected.

See Also

MeasurementSetup Class | Agilent.N4010.EdrDriver.Measurements Namespace


AcquisitionTime Property

Agilent N4010A Bluetooth EDR Driver

MeasurementSetup.AcquisitionTime Property

Sets the maximum acquisition time to capture a packet to do EDR measurements on.

public double AcquisitionTime {get; set;}

Property Value

Unit | s
Default | 625e-6 (625µs)
Resolution | 10e-9 (10ns)
Minimum | 100e-6 (100µs)
Maximum | 5.242e-3 (5.242ms)

Remarks

Cannot be set while a measurement is running, a calibration or self test is in progress, or the source is running.

Exceptions

Exception Type | Condition
AcquisitionTimeOutOfRangeException | Invalid value provided
MeasurementRunningException | A measurement is currently running. You can find out if a measurement is running by reading the MeasurementRunning property.
SourceActiveException | The source is currently running or a sequence file is selected.

See Also

MeasurementSetup Class | Agilent.N4010.EdrDriver.Measurements Namespace


ChannelFrequency Property

Agilent N4010A Bluetooth EDR Driver

MeasurementSetup.ChannelFrequency Property

Measurement frequency.

public double ChannelFrequency {get; set;}

Property Value

Unit | Hz
Default | 2 441 000 000 (2.441GHz)
Resolution | 1 000 000 (1MHz)
Minimum | 2 402 000 000 (2.402GHz)
Maximum | 2 480 000 000 (2.480GHz)

Remarks

Cannot be set while a measurement is running, a calibration or self test is in progress, or the source is running.

Exceptions

Exception Type | Condition
ChannelFrequencyOutOfRangeException | The frequency value you gave is outside the valid range defined above.
MeasurementRunningException | A measurement is currently running. You can find out if a measurement is running by reading the MeasurementRunning property.
SourceActiveException | The source is currently running or a sequence file is selected.

See Also

MeasurementSetup Class | Agilent.N4010.EdrDriver.Measurements Namespace


ExpectedPacketType Property

Agilent N4010A Bluetooth EDR Driver

MeasurementSetup.ExpectedPacketType Property

Expected packet type.

public Agilent.N4010.EdrDriver.Enums.ExpectedPacketType ExpectedPacketType {get; set;}

Property Value

  • ThreeDh1 - A 3-DH1 packet
  • ThreeDh3 - A 3-DH3 packet
  • ThreeDh5 - A 3-DH5 packet
  • TwoDh1 - A 2-DH1 packet
  • TwoDh3 - A 2-DH3 packet
  • TwoDh5 - A 2-DH5 packet

Default - TwoDh1

Remarks

Cannot be set while a measurement is running, a calibration or self test is in progress, or the source is running.

Exceptions

Exception Type | Condition
ExpectedPacketTypeOutOfRangeException | Invalid value provided
MeasurementRunningException | A measurement is currently running. You can find out if a measurement is running by reading the MeasurementRunning property.
SourceActiveException | The source is currently running or a sequence file is selected.

See Also

MeasurementSetup Class | Agilent.N4010.EdrDriver.Measurements Namespace


IFBandwidth Property

Agilent N4010A Bluetooth EDR Driver

MeasurementSetup.IFBandwidth Property

Instrument IF Bandwidth

public Agilent.N4010.EdrDriver.Enums.IFBandwidth IFBandwidth {get; set;}

Property Value

  • IF_1_3MHz - instrument's IF bandwidth set to 1.3MHz.
  • IF_3MHz - instrument's IF bandwidth set to 3MHz.
  • IF_5MHz - instrument's IF bandwidth set to 5MHz.

Default - IF_1_3MHz

Remarks

Cannot be set while a measurement is running, a calibration or self test is in progress, or the source is running.

Exceptions

Exception Type | Condition
IFBandwidthOutOfRangeException | Invalid value provided
MeasurementRunningException | A measurement is currently running. You can find out if a measurement is running by reading the MeasurementRunning property.
SourceActiveException | The source is currently running or a sequence file is selected.

See Also

MeasurementSetup Class | Agilent.N4010.EdrDriver.Measurements Namespace


PowerRange Property

Agilent N4010A Bluetooth EDR Driver

MeasurementSetup.PowerRange Property

Input power range.

public double PowerRange {get; set;}

Property Value

Unit | dBm
Default | 0
Resolution | 5
Minimum | -60
Maximum | 25

Remarks

Cannot be set while a measurement is running, a calibration or self test is in progress, or the source is running.

Exceptions

Exception Type | Condition
PowerLevelOutOfRangeException | Invalid value provided
MeasurementRunningException | A measurement is currently running. You can find out if a measurement is running by reading the MeasurementRunning property.
SourceActiveException | The source is currently running or a sequence file is selected.
PowerRangeOutOfRangeException | Power Range value provided is outside the valid range

See Also

MeasurementSetup Class | Agilent.N4010.EdrDriver.Measurements Namespace


TriggerIdle Property

Agilent N4010A Bluetooth EDR Driver

MeasurementSetup.TriggerIdle Property

Trigger Idle

public double TriggerIdle {get; set;}

Property Value

Unit | s
Default | 655.36e-6
Resolution | 1e-8
Minimum | 20e-9
Maximum | 655.36e-6

Remarks

Cannot be set while a measurement is running or the source is running.

Exceptions

Exception Type | Condition
TriggerIdleOutOfRangeException | Invalid value provided
MeasurementRunningException | A measurement is currently running. You can find out if a measurement is running by reading the MeasurementRunning property.
SourceActiveException | The source is currently running or a sequence file is selected.

See Also

MeasurementSetup Class | Agilent.N4010.EdrDriver.Measurements Namespace


TriggerLevel Property

Agilent N4010A Bluetooth EDR Driver

MeasurementSetup.TriggerLevel Property

Trigger Level

public double TriggerLevel {get; set;}

Property Value

Unit | dBm
Default | -10
Resolution | 0.01
Minimum | -100
Maximum | 20

Remarks

Cannot be set while a measurement is running or the source is running.

Exceptions

Exception Type | Condition
TriggerLevelOutOfRangeException | Invalid value provided
MeasurementRunningException | A measurement is currently running. You can find out if a measurement is running by reading the MeasurementRunning property.
SourceActiveException | The source is currently running or a sequence file is selected.

See Also

MeasurementSetup Class | Agilent.N4010.EdrDriver.Measurements Namespace


TriggerSlope Property

Agilent N4010A Bluetooth EDR Driver

MeasurementSetup.TriggerSlope Property

Trigger Slope

public Agilent.N4010.EdrDriver.Enums.TriggerSlope TriggerSlope {get; set;}

Property Value

  • Positive - level-triggered on a voltage passing positively through the voltage given in TriggerLevel
  • Negative - level-triggered on a voltage passing negatively through the voltage given in TriggerLevel

Default - Negative

Remarks

Cannot be set while a measurement is running, a calibration or self test is in progress, or the source is running.

Exceptions

Exception Type | Condition
TriggerSlopeOutOfRangeException | Invalid value provided
MeasurementRunningException | A measurement is currently running. You can find out if a measurement is running by reading the MeasurementRunning property.
SourceActiveException | The source is currently running or a sequence file is selected.

See Also

MeasurementSetup Class | Agilent.N4010.EdrDriver.Measurements Namespace


TriggerStyle Property

Agilent N4010A Bluetooth EDR Driver

MeasurementSetup.TriggerStyle Property

Trigger Style

public Agilent.N4010.EdrDriver.Enums.TriggerStyle TriggerStyle {get; set;}

Property Value

  • Burst - level-triggered on a voltage passing through the voltage given in TriggerLevel
  • External - external trigger via BNC connector on rear panel

Default - Burst

Remarks

Cannot be set while a measurement is running, a calibration or self test is in progress, or the source is running.

Exceptions

Exception Type | Condition
TriggerStyleOutOfRangeException | Invalid value provided
MeasurementRunningException | A measurement is currently running. You can find out if a measurement is running by reading the MeasurementRunning property.
SourceActiveException | The source is currently running or a sequence file is selected.

See Also

MeasurementSetup Class | Agilent.N4010.EdrDriver.Measurements Namespace


Power Class

Class to sample the generic power of input data

For a list of all members of this type, see Power Members.

System.Object
Agilent.N4010.EdrDriver.Measurements.MeasurementBaseFrontEnd
Agilent.N4010.EdrDriver.Measurements.Power

public class Power : MeasurementBaseFrontEnd

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Agilent.N4010.EdrDriver.Measurements

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

Power Members | Agilent.N4010.EdrDriver.Measurements Namespace


Power Members

Power overview

Public Instance Properties

MeasurementSuccess (inherited from MeasurementBaseFrontEnd) |
Results | The output results for the measurement
Settings | The input settings for the measurement

Public Instance Methods

CalcResults (inherited from MeasurementBaseFrontEnd) | Calculate the results based on the sampled iq and p0 bit already stored in Basebandiq and DataMarker results.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run (inherited from MeasurementBaseFrontEnd) | Run the measurement.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Power Class | Agilent.N4010.EdrDriver.Measurements Namespace


Power Properties

The properties of the Power class are listed below. For a complete list of Power class members, see the Power Members topic.

Public Instance Properties

MeasurementSuccess (inherited from MeasurementBaseFrontEnd) |
Results | The output results for the measurement
Settings | The input settings for the measurement

See Also

Power Class | Agilent.N4010.EdrDriver.Measurements Namespace


Results Property

Agilent N4010A Bluetooth EDR Driver

Power.Results Property

The output results for the measurement

public Results.tPowerResults Results {get;}

See Also

Power Class | Agilent.N4010.EdrDriver.Measurements Namespace


Settings Property

Agilent N4010A Bluetooth EDR Driver

Power.Settings Property

The input settings for the measurement

public Settings.tPowerSettings Settings {get; set;}

See Also

Power Class | Agilent.N4010.EdrDriver.Measurements Namespace


RelativePower Class

Average Power for both the GFSK and DPSK part of the measurement.

For a list of all members of this type, see RelativePower Members.

System.Object
Agilent.N4010.EdrDriver.Measurements.MeasurementBaseFrontEnd
Agilent.N4010.EdrDriver.Measurements.RelativePower

public class RelativePower : MeasurementBaseFrontEnd

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This is a power measurement which runs regardless of modulation format.

Requirements

Namespace: Agilent.N4010.EdrDriver.Measurements

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

RelativePower Members | Agilent.N4010.EdrDriver.Measurements Namespace


RelativePower Members

RelativePower overview

Public Instance Properties

MeasurementSuccess (inherited from MeasurementBaseFrontEnd) |
Results | The output results for the measurement
Settings |

Public Instance Methods

CalcResults (inherited from MeasurementBaseFrontEnd) | Calculate the results based on the sampled iq and p0 bit already stored in Basebandiq and DataMarker results.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Run (inherited from MeasurementBaseFrontEnd) | Run the measurement.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RelativePower Class | Agilent.N4010.EdrDriver.Measurements Namespace


RelativePower Properties

The properties of the RelativePower class are listed below. For a complete list of RelativePower class members, see the RelativePower Members topic.

Public Instance Properties

MeasurementSuccess (inherited from MeasurementBaseFrontEnd) |
Results | The output results for the measurement
Settings |

See Also

RelativePower Class | Agilent.N4010.EdrDriver.Measurements Namespace


Results Property

Agilent N4010A Bluetooth EDR Driver

RelativePower.Results Property

The output results for the measurement

public Results.tRelativePowerResults Results {get;}

See Also

RelativePower Class | Agilent.N4010.EdrDriver.Measurements Namespace


Settings Property

Agilent N4010A Bluetooth EDR Driver

RelativePower.Settings Property

public Settings.tRelativePowerSettings Settings {get; set;}

See Also

RelativePower Class | Agilent.N4010.EdrDriver.Measurements Namespace


Agilent.N4010.EdrDriver.Measurements.Results

Agilent N4010A Bluetooth EDR Driver

Agilent.N4010.EdrDriver.Measurements.Results Namespace

Namespace hierarchy

Classes

Class | Description
tDataMarkersResults | The data markers from the sampled data.

Structures

Structure | Description
tBasebandIqResults | The results for the Baseband IQ measurement.
tCarrierStabilityModulationAccuracyResults | The results for the Carrier Frequency and Modualtion Accuracy measurement.
tDifferentialPhaseEncodingResults | The results for the Differential Phase Encoding measurement.
tPowerResults | The settings for the Power measurement.
tRelativePowerResults |


tBasebandIqResults Structure

The results for the Baseband IQ measurement.

For a list of all members of this type, see tBasebandIqResults Members.

System.Object
System.ValueType
Agilent.N4010.EdrDriver.Measurements.Results.tBasebandIqResults

public struct tBasebandIqResults

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Agilent.N4010.EdrDriver.Measurements.Results

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

tBasebandIqResults Members | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tBasebandIqResults Members

tBasebandIqResults overview

Public Instance Fields

IData | Array containing all I samples
NumberSamples | Number of samples sampled!
QData | Array containing all Q samples

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

tBasebandIqResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tBasebandIqResults Fields

The fields of the tBasebandIqResults structure are listed below. For a complete list of tBasebandIqResults structure members, see the tBasebandIqResults Members topic.

Public Instance Fields

IData | Array containing all I samples
NumberSamples | Number of samples sampled!
QData | Array containing all Q samples

See Also

tBasebandIqResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tBasebandIqResults.IData Field

Array containing all I samples

public float[] IData;

See Also

tBasebandIqResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tBasebandIqResults.NumberSamples Field

Number of samples sampled!

public int NumberSamples;

See Also

tBasebandIqResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tBasebandIqResults.QData Field

Array containing all Q samples

public float[] QData;

See Also

tBasebandIqResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tCarrierStabilityModulationAccuracyResults Structure

The results for the Carrier Frequency and Modualtion Accuracy measurement.

For a list of all members of this type, see tCarrierStabilityModulationAccuracyResults Members.

System.Object
System.ValueType
Agilent.N4010.EdrDriver.Measurements.Results.tCarrierStabilityModulationAccuracyResults

public struct tCarrierStabilityModulationAccuracyResults

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Agilent.N4010.EdrDriver.Measurements.Results

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

tCarrierStabilityModulationAccuracyResults Members | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tCarrierStabilityModulationAccuracyResults Members

tCarrierStabilityModulationAccuracyResults overview

Public Instance Fields

BlockFrequencyErrorMax | Return the maximum block frequency error of the payload data
BlockFrequencyErrorVector | The block frequency errors for all packets
ConstellationVector | The constellation vector of the 50 symbol payload blocks.
DevmVector | The DEVM per symbol vector.
GuardInterval | The Guard Intervals of the sampled packets.
GuardIntervalAverage | The average Guard Interval for all packets.
GuardIntervalMax | The maximum Guard Interval for all packets.
GuardIntervalMin | The minimum Guard Interval for all packets.
InitialFrequencyErrorMax | Return the initial frequency errors of the packet headers
InitialFrequencyErrorVector | The initial frequency errors for all packets
NinetyNinthDevm | Return the value of which 99% of rms DEVM measurements are below
NumberOfBlocks | The number of 50 symbol blocks the calculation is done over.
PeakDevmMax | Return the maximum peak DEVM per payload block.
PeakDevmVector | The peak DEVM vector.
RmsDevmMax | Return the maximum rms DEVM per payload block.
RmsDevmVector | The RMD DEVM vector.
TotalFrequencyErrorMax | The maximum total frequency error.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

tCarrierStabilityModulationAccuracyResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tCarrierStabilityModulationAccuracyResults Fields

The fields of the tCarrierStabilityModulationAccuracyResults structure are listed below. For a complete list of tCarrierStabilityModulationAccuracyResults structure members, see the tCarrierStabilityModulationAccuracyResults Members topic.

Public Instance Fields

BlockFrequencyErrorMax | Return the maximum block frequency error of the payload data
BlockFrequencyErrorVector | The block frequency errors for all packets
ConstellationVector | The constellation vector of the 50 symbol payload blocks.
DevmVector | The DEVM per symbol vector.
GuardInterval | The Guard Intervals of the sampled packets.
GuardIntervalAverage | The average Guard Interval for all packets.
GuardIntervalMax | The maximum Guard Interval for all packets.
GuardIntervalMin | The minimum Guard Interval for all packets.
InitialFrequencyErrorMax | Return the initial frequency errors of the packet headers
InitialFrequencyErrorVector | The initial frequency errors for all packets
NinetyNinthDevm | Return the value of which 99% of rms DEVM measurements are below
NumberOfBlocks | The number of 50 symbol blocks the calculation is done over.
PeakDevmMax | Return the maximum peak DEVM per payload block.
PeakDevmVector | The peak DEVM vector.
RmsDevmMax | Return the maximum rms DEVM per payload block.
RmsDevmVector | The RMD DEVM vector.
TotalFrequencyErrorMax | The maximum total frequency error.

See Also

tCarrierStabilityModulationAccuracyResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tCarrierStabilityModulationAccuracyResults.BlockFrequencyErrorMax Field

Return the maximum block frequency error of the payload data

public float BlockFrequencyErrorMax;

See Also

tCarrierStabilityModulationAccuracyResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tCarrierStabilityModulationAccuracyResults.BlockFrequencyErrorVector Field

The block frequency errors for all packets

public float[] BlockFrequencyErrorVector;

See Also

tCarrierStabilityModulationAccuracyResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tCarrierStabilityModulationAccuracyResults.ConstellationVector Field

The constellation vector of the 50 symbol payload blocks.

public float[] ConstellationVector;

See Also

tCarrierStabilityModulationAccuracyResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tCarrierStabilityModulationAccuracyResults.DevmVector Field

The DEVM per symbol vector.

public float[] DevmVector;

See Also

tCarrierStabilityModulationAccuracyResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tCarrierStabilityModulationAccuracyResults.GuardInterval Field

The Guard Intervals of the sampled packets.

public float[] GuardInterval;

See Also

tCarrierStabilityModulationAccuracyResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tCarrierStabilityModulationAccuracyResults.GuardIntervalAverage Field

The average Guard Interval for all packets.

public float GuardIntervalAverage;

See Also

tCarrierStabilityModulationAccuracyResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tCarrierStabilityModulationAccuracyResults.GuardIntervalMax Field

The maximum Guard Interval for all packets.

public float GuardIntervalMax;

See Also

tCarrierStabilityModulationAccuracyResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tCarrierStabilityModulationAccuracyResults.GuardIntervalMin Field

The minimum Guard Interval for all packets.

public float GuardIntervalMin;

See Also

tCarrierStabilityModulationAccuracyResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tCarrierStabilityModulationAccuracyResults.InitialFrequencyErrorMax Field

Return the initial frequency errors of the packet headers

public float InitialFrequencyErrorMax;

See Also

tCarrierStabilityModulationAccuracyResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tCarrierStabilityModulationAccuracyResults.InitialFrequencyErrorVector Field

The initial frequency errors for all packets

public float[] InitialFrequencyErrorVector;

See Also

tCarrierStabilityModulationAccuracyResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tCarrierStabilityModulationAccuracyResults.NinetyNinthDevm Field

Return the value of which 99% of rms DEVM measurements are below

public float NinetyNinthDevm;

See Also

tCarrierStabilityModulationAccuracyResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tCarrierStabilityModulationAccuracyResults.NumberOfBlocks Field

The number of 50 symbol blocks the calculation is done over.

public int NumberOfBlocks;

See Also

tCarrierStabilityModulationAccuracyResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tCarrierStabilityModulationAccuracyResults.PeakDevmMax Field

Return the maximum peak DEVM per payload block.

public float PeakDevmMax;

See Also

tCarrierStabilityModulationAccuracyResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tCarrierStabilityModulationAccuracyResults.PeakDevmVector Field

The peak DEVM vector.

public float[] PeakDevmVector;

See Also

tCarrierStabilityModulationAccuracyResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tCarrierStabilityModulationAccuracyResults.RmsDevmMax Field

Return the maximum rms DEVM per payload block.

public float RmsDevmMax;

See Also

tCarrierStabilityModulationAccuracyResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tCarrierStabilityModulationAccuracyResults.RmsDevmVector Field

The RMD DEVM vector.

public float[] RmsDevmVector;

See Also

tCarrierStabilityModulationAccuracyResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tCarrierStabilityModulationAccuracyResults.TotalFrequencyErrorMax Field

The maximum total frequency error.

public float TotalFrequencyErrorMax;

See Also

tCarrierStabilityModulationAccuracyResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tDataMarkersResults Class

The data markers from the sampled data.

For a list of all members of this type, see tDataMarkersResults Members.

System.Object
Agilent.N4010.EdrDriver.Measurements.Results.tDataMarkersResults

public class tDataMarkersResults

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Agilent.N4010.EdrDriver.Measurements.Results

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

tDataMarkersResults Members | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tDataMarkersResults Members

tDataMarkersResults overview

Public Instance Constructors

tDataMarkersResults Constructor Initializes a new instance of the tDataMarkersResults class.

Public Instance Fields

FallingEdgeIndex | The falling edge of the burst.
GfskEndIndex | The index location of the end of the GFSK header
P0Index | The index location of P0
PayloadEndIndex | The index location of the end of the payload.
PayloadStartIndex | The index location of the start of the payload
RisingEdgeIndex | The rising edge of the burst.
SyncSequenceIndex | The index location of the synchronisation sequence.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

tDataMarkersResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tDataMarkersResults Constructor

Initializes a new instance of the tDataMarkersResults class.

public tDataMarkersResults();

See Also

tDataMarkersResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tDataMarkersResults Fields

The fields of the tDataMarkersResults class are listed below. For a complete list of tDataMarkersResults class members, see the tDataMarkersResults Members topic.

Public Instance Fields

FallingEdgeIndex | The falling edge of the burst.
GfskEndIndex | The index location of the end of the GFSK header
P0Index | The index location of P0
PayloadEndIndex | The index location of the end of the payload.
PayloadStartIndex | The index location of the start of the payload
RisingEdgeIndex | The rising edge of the burst.
SyncSequenceIndex | The index location of the synchronisation sequence.

See Also

tDataMarkersResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tDataMarkersResults.FallingEdgeIndex Field

The falling edge of the burst.

public int FallingEdgeIndex;

See Also

tDataMarkersResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tDataMarkersResults.GfskEndIndex Field

The index location of the end of the GFSK header

public int GfskEndIndex;

See Also

tDataMarkersResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tDataMarkersResults.P0Index Field

The index location of P0

public int P0Index;

See Also

tDataMarkersResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tDataMarkersResults.PayloadEndIndex Field

The index location of the end of the payload.

public int PayloadEndIndex;

See Also

tDataMarkersResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tDataMarkersResults.PayloadStartIndex Field

The index location of the start of the payload

public int PayloadStartIndex;

See Also

tDataMarkersResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tDataMarkersResults.RisingEdgeIndex Field

The rising edge of the burst.

public int RisingEdgeIndex;

See Also

tDataMarkersResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tDataMarkersResults.SyncSequenceIndex Field

The index location of the synchronisation sequence.

public int SyncSequenceIndex;

See Also

tDataMarkersResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tDifferentialPhaseEncodingResults Structure

The results for the Differential Phase Encoding measurement.

For a list of all members of this type, see tDifferentialPhaseEncodingResults Members.

System.Object
System.ValueType
Agilent.N4010.EdrDriver.Measurements.Results.tDifferentialPhaseEncodingResults

public struct tDifferentialPhaseEncodingResults

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Agilent.N4010.EdrDriver.Measurements.Results

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

tDifferentialPhaseEncodingResults Members | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tDifferentialPhaseEncodingResults Members

tDifferentialPhaseEncodingResults overview

Public Instance Fields

Ber | The Bit error Rate as a percentage.
ConstellationVector | The constellation vector of the payload.
ErrorIndices | The index of the errors.
GuardInterval | The Guard Intervals of the sampled packets.
GuardIntervalAverage | The average Guard Interval for all packets.
GuardIntervalMax | The maximum Guard Interval for all packets.
GuardIntervalMin | The minimum Guard Interval for all packets.
NumberBitsError | The total number of bits in error for the measurement.
NumberBitsTotal | The total number of bits for the measurement.
NumberCorrectPackets | The number of packets decoded which had the correct payload.
NumberPackets | The total number of packets over which the Differential Phase Encoding was done over.
PacketErrorRate | The packet error rate as a percentage
PayloadData | The payload data of the last sampled packet.
PayloadDataIdeal | The ideal payload data of the last sampled packet.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

tDifferentialPhaseEncodingResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tDifferentialPhaseEncodingResults Fields

The fields of the tDifferentialPhaseEncodingResults structure are listed below. For a complete list of tDifferentialPhaseEncodingResults structure members, see the tDifferentialPhaseEncodingResults Members topic.

Public Instance Fields

Ber | The Bit error Rate as a percentage.
ConstellationVector | The constellation vector of the payload.
ErrorIndices | The index of the errors.
GuardInterval | The Guard Intervals of the sampled packets.
GuardIntervalAverage | The average Guard Interval for all packets.
GuardIntervalMax | The maximum Guard Interval for all packets.
GuardIntervalMin | The minimum Guard Interval for all packets.
NumberBitsError | The total number of bits in error for the measurement.
NumberBitsTotal | The total number of bits for the measurement.
NumberCorrectPackets | The number of packets decoded which had the correct payload.
NumberPackets | The total number of packets over which the Differential Phase Encoding was done over.
PacketErrorRate | The packet error rate as a percentage
PayloadData | The payload data of the last sampled packet.
PayloadDataIdeal | The ideal payload data of the last sampled packet.

See Also

tDifferentialPhaseEncodingResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tDifferentialPhaseEncodingResults.Ber Field

The Bit error Rate as a percentage.

public float Ber;

See Also

tDifferentialPhaseEncodingResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tDifferentialPhaseEncodingResults.ConstellationVector Field

The constellation vector of the payload.

public float[] ConstellationVector;

See Also

tDifferentialPhaseEncodingResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tDifferentialPhaseEncodingResults.ErrorIndices Field

The index of the errors.

public int[] ErrorIndices;

See Also

tDifferentialPhaseEncodingResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tDifferentialPhaseEncodingResults.GuardInterval Field

The Guard Intervals of the sampled packets.

public float[] GuardInterval;

See Also

tDifferentialPhaseEncodingResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tDifferentialPhaseEncodingResults.GuardIntervalAverage Field

The average Guard Interval for all packets.

public float GuardIntervalAverage;

See Also

tDifferentialPhaseEncodingResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tDifferentialPhaseEncodingResults.GuardIntervalMax Field

The maximum Guard Interval for all packets.

public float GuardIntervalMax;

See Also

tDifferentialPhaseEncodingResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tDifferentialPhaseEncodingResults.GuardIntervalMin Field

The minimum Guard Interval for all packets.

public float GuardIntervalMin;

See Also

tDifferentialPhaseEncodingResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tDifferentialPhaseEncodingResults.NumberBitsError Field

The total number of bits in error for the measurement.

public int NumberBitsError;

See Also

tDifferentialPhaseEncodingResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tDifferentialPhaseEncodingResults.NumberBitsTotal Field

The total number of bits for the measurement.

public int NumberBitsTotal;

See Also

tDifferentialPhaseEncodingResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tDifferentialPhaseEncodingResults.NumberCorrectPackets Field

The number of packets decoded which had the correct payload.

public int NumberCorrectPackets;

See Also

tDifferentialPhaseEncodingResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tDifferentialPhaseEncodingResults.NumberPackets Field

The total number of packets over which the Differential Phase Encoding was done over.

public int NumberPackets;

See Also

tDifferentialPhaseEncodingResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tDifferentialPhaseEncodingResults.PacketErrorRate Field

The packet error rate as a percentage

public float PacketErrorRate;

See Also

tDifferentialPhaseEncodingResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tDifferentialPhaseEncodingResults.PayloadData Field

The payload data of the last sampled packet.

public bool[] PayloadData;

See Also

tDifferentialPhaseEncodingResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tDifferentialPhaseEncodingResults.PayloadDataIdeal Field

The ideal payload data of the last sampled packet.

public bool[] PayloadDataIdeal;

See Also

tDifferentialPhaseEncodingResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tPowerResults Structure

The settings for the Power measurement.

For a list of all members of this type, see tPowerResults Members.

System.Object
System.ValueType
Agilent.N4010.EdrDriver.Measurements.Results.tPowerResults

public struct tPowerResults

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Agilent.N4010.EdrDriver.Measurements.Results

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

tPowerResults Members | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tPowerResults Members

tPowerResults overview

Public Instance Fields

NumberSamples | Number of samples.
PowerArray | Array of sampled power.

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

tPowerResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tPowerResults Fields

The fields of the tPowerResults structure are listed below. For a complete list of tPowerResults structure members, see the tPowerResults Members topic.

Public Instance Fields

NumberSamples | Number of samples.
PowerArray | Array of sampled power.

See Also

tPowerResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tPowerResults.NumberSamples Field

Number of samples.

public int NumberSamples;

See Also

tPowerResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tPowerResults.PowerArray Field

Array of sampled power.

public float[] PowerArray;

See Also

tPowerResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tRelativePowerResults Structure

For a list of all members of this type, see tRelativePowerResults Members.

System.Object
System.ValueType
Agilent.N4010.EdrDriver.Measurements.Results.tRelativePowerResults

public struct tRelativePowerResults

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Agilent.N4010.EdrDriver.Measurements.Results

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

tRelativePowerResults Members | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tRelativePowerResults Members

tRelativePowerResults overview

Public Instance Fields

AveragePowerDifference
AveragePowerDpsk
AveragePowerGfsk
CalculatedPacketType
ConstellationVector
GuardInterval
Power

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

tRelativePowerResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tRelativePowerResults Fields

The fields of the tRelativePowerResults structure are listed below. For a complete list of tRelativePowerResults structure members, see the tRelativePowerResults Members topic.

Public Instance Fields

AveragePowerDifference
AveragePowerDpsk
AveragePowerGfsk
CalculatedPacketType
ConstellationVector
GuardInterval
Power

See Also

tRelativePowerResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tRelativePowerResults.AveragePowerDifference Field

public float AveragePowerDifference;

See Also

tRelativePowerResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tRelativePowerResults.AveragePowerDpsk Field

public float AveragePowerDpsk;

See Also

tRelativePowerResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tRelativePowerResults.AveragePowerGfsk Field

public float AveragePowerGfsk;

See Also

tRelativePowerResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tRelativePowerResults.CalculatedPacketType Field

public CalculatedEdrPacketType CalculatedPacketType;

See Also

tRelativePowerResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tRelativePowerResults.ConstellationVector Field

public float[] ConstellationVector;

See Also

tRelativePowerResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tRelativePowerResults.GuardInterval Field

public float GuardInterval;

See Also

tRelativePowerResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


tRelativePowerResults.Power Field

public float[] Power;

See Also

tRelativePowerResults Class | Agilent.N4010.EdrDriver.Measurements.Results Namespace


Agilent.N4010.EdrDriver.Measurements.Settings

Agilent N4010A Bluetooth EDR Driver

Agilent.N4010.EdrDriver.Measurements.Settings Namespace

Namespace hierarchy

Classes

Class | Description
tBasebandIqSettings | The settings for the Baseband IQ measurement.
tCarrierStabilityModulationAccuracySettings | The settings for the Carrier Frequency and Modualtion Accuracy measurement.
tDifferentialPhaseEncodingSettings | The settings for the Differential Phase Encoding measurement.
tPowerSettings | The settings for the Power measurement.
tRelativePowerSettings | The settings for the Relative Power measurement.


tBasebandIqSettings Class

The settings for the Baseband IQ measurement.

For a list of all members of this type, see tBasebandIqSettings Members.

System.Object
Agilent.N4010.EdrDriver.Measurements.Settings.tBasebandIqSettings

public class tBasebandIqSettings

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Agilent.N4010.EdrDriver.Measurements.Settings

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

tBasebandIqSettings Members | Agilent.N4010.EdrDriver.Measurements.Settings Namespace


tBasebandIqSettings Members

tBasebandIqSettings overview

Public Instance Constructors

tBasebandIqSettings Constructor Initializes a new instance of the tBasebandIqSettings class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

tBasebandIqSettings Class | Agilent.N4010.EdrDriver.Measurements.Settings Namespace


tBasebandIqSettings Constructor

Initializes a new instance of the tBasebandIqSettings class.

public tBasebandIqSettings();

See Also

tBasebandIqSettings Class | Agilent.N4010.EdrDriver.Measurements.Settings Namespace


tCarrierStabilityModulationAccuracySettings Class

The settings for the Carrier Frequency and Modualtion Accuracy measurement.

For a list of all members of this type, see tCarrierStabilityModulationAccuracySettings Members.

System.Object
Agilent.N4010.EdrDriver.Measurements.Settings.tCarrierStabilityModulationAccuracySettings

public class tCarrierStabilityModulationAccuracySettings

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Agilent.N4010.EdrDriver.Measurements.Settings

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

tCarrierStabilityModulationAccuracySettings Members | Agilent.N4010.EdrDriver.Measurements.Settings Namespace


tCarrierStabilityModulationAccuracySettings Members

tCarrierStabilityModulationAccuracySettings overview

Public Instance Constructors

tCarrierStabilityModulationAccuracySettings Constructor Initializes a new instance of the tCarrierStabilityModulationAccuracySettings class.

Public Instance Properties

NumberOfPacketsMax The maximum number of packets to be sampled

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

tCarrierStabilityModulationAccuracySettings Class | Agilent.N4010.EdrDriver.Measurements.Settings Namespace


tCarrierStabilityModulationAccuracySettings Constructor

Initializes a new instance of the tCarrierStabilityModulationAccuracySettings class.

public tCarrierStabilityModulationAccuracySettings();

See Also

tCarrierStabilityModulationAccuracySettings Class | Agilent.N4010.EdrDriver.Measurements.Settings Namespace


tCarrierStabilityModulationAccuracySettings Properties

The properties of the tCarrierStabilityModulationAccuracySettings class are listed below. For a complete list of tCarrierStabilityModulationAccuracySettings class members, see the tCarrierStabilityModulationAccuracySettings Members topic.

Public Instance Properties

NumberOfPacketsMax The maximum number of packets to be sampled

See Also

tCarrierStabilityModulationAccuracySettings Class | Agilent.N4010.EdrDriver.Measurements.Settings Namespace


NumberOfPacketsMax Property

Agilent N4010A Bluetooth EDR Driver

tCarrierStabilityModulationAccuracySettings.NumberOfPacketsMax Property

The maximum number of packets to be sampled

public int NumberOfPacketsMax {get; set;}

See Also

tCarrierStabilityModulationAccuracySettings Class | Agilent.N4010.EdrDriver.Measurements.Settings Namespace


tDifferentialPhaseEncodingSettings Class

The settings for the Differential Phase Encoding measurement.

For a list of all members of this type, see tDifferentialPhaseEncodingSettings Members.

System.Object
Agilent.N4010.EdrDriver.Measurements.Settings.tDifferentialPhaseEncodingSettings

public class tDifferentialPhaseEncodingSettings

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Agilent.N4010.EdrDriver.Measurements.Settings

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

tDifferentialPhaseEncodingSettings Members | Agilent.N4010.EdrDriver.Measurements.Settings Namespace


tDifferentialPhaseEncodingSettings Members

tDifferentialPhaseEncodingSettings overview

Public Instance Constructors

tDifferentialPhaseEncodingSettings Constructor Initializes a new instance of the tDifferentialPhaseEncodingSettings class.

Public Instance Properties

NumberOfPackets Number of packets to do the measurement on.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

tDifferentialPhaseEncodingSettings Class | Agilent.N4010.EdrDriver.Measurements.Settings Namespace


tDifferentialPhaseEncodingSettings Constructor

Initializes a new instance of the tDifferentialPhaseEncodingSettings class.

public tDifferentialPhaseEncodingSettings();

See Also

tDifferentialPhaseEncodingSettings Class | Agilent.N4010.EdrDriver.Measurements.Settings Namespace


tDifferentialPhaseEncodingSettings Properties

The properties of the tDifferentialPhaseEncodingSettings class are listed below. For a complete list of tDifferentialPhaseEncodingSettings class members, see the tDifferentialPhaseEncodingSettings Members topic.

Public Instance Properties

NumberOfPackets Number of packets to do the measurement on.

See Also

tDifferentialPhaseEncodingSettings Class | Agilent.N4010.EdrDriver.Measurements.Settings Namespace


NumberOfPackets Property

Agilent N4010A Bluetooth EDR Driver

tDifferentialPhaseEncodingSettings.NumberOfPackets Property

Number of packets to do the measurement on.

public int NumberOfPackets {get; set;}

See Also

tDifferentialPhaseEncodingSettings Class | Agilent.N4010.EdrDriver.Measurements.Settings Namespace


tPowerSettings Class

The settings for the Power measurement.

For a list of all members of this type, see tPowerSettings Members.

System.Object
Agilent.N4010.EdrDriver.Measurements.Settings.tPowerSettings

public class tPowerSettings

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Agilent.N4010.EdrDriver.Measurements.Settings

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

tPowerSettings Members | Agilent.N4010.EdrDriver.Measurements.Settings Namespace


tPowerSettings Members

tPowerSettings overview

Public Instance Constructors

tPowerSettings Constructor Initializes a new instance of the tPowerSettings class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

tPowerSettings Class | Agilent.N4010.EdrDriver.Measurements.Settings Namespace


tPowerSettings Constructor

Initializes a new instance of the tPowerSettings class.

public tPowerSettings();

See Also

tPowerSettings Class | Agilent.N4010.EdrDriver.Measurements.Settings Namespace


tRelativePowerSettings Class

The settings for the Relative Power measurement.

For a list of all members of this type, see tRelativePowerSettings Members.

System.Object
Agilent.N4010.EdrDriver.Measurements.Settings.tRelativePowerSettings

public class tRelativePowerSettings

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Agilent.N4010.EdrDriver.Measurements.Settings

Assembly: Agilent.N4010.EdrDriver (in Agilent.N4010.EdrDriver.dll)

See Also

tRelativePowerSettings Members | Agilent.N4010.EdrDriver.Measurements.Settings Namespace


tRelativePowerSettings Members

tRelativePowerSettings overview

Public Instance Constructors

tRelativePowerSettings Constructor Initializes a new instance of the tRelativePowerSettings class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

tRelativePowerSettings Class | Agilent.N4010.EdrDriver.Measurements.Settings Namespace


tRelativePowerSettings Constructor

Initializes a new instance of the tRelativePowerSettings class.

public tRelativePowerSettings();

See Also

tRelativePowerSettings Class | Agilent.N4010.EdrDriver.Measurements.Settings Namespace


EDR Arb Packet Settings

N4010A EDR Arb TX Packet Settings

Rate | Packet Type | Max packet length (bytes) | BD_ADDRess | Idle Time | LT_ADDress
EDR (2M bit per sec) | 2-DH1 | 54 | BDBDBDBDBDBD | 1-slot | 0
 | 2-DH3 | 367 | BDBDBDBDBDBD | 3-slots | 0
 | 2-DH5 | 679 | BDBDBDBDBDBD | 5-slots | 0
EDR (3M bit per sec) | 3-DH1 | 83 | BDBDBDBDBDBD | 1-slot | 0
 | 3-DH3 | 552 | BDBDBDBDBDBD | 3-slots | 0
 | 3-DH5 | 1021 | BDBDBDBDBDBD | 5-slots | 0

Note: Burst to Idle ratio is 50/50

For example, 3-DH5, consists of 5-slots data and 5-slots idle or 2-DH3, consists of 3-slots data and 3 slots idle


1. Revision History

Date | Revision | Comments
16-Aug-2005 | 1 | Initial draft
19-Aug-2005 | 2 | Minor updates following review
02-Sep-2005 | 3 | Updates – COM DLL available, VB 6.0 example available


2. Table of Contents

1. Revision History.. 2

2. Table of Contents. 3

3. Introduction.. 4

3.1. Purpose and Scope of Document. 4

3.2. DLL Compatibility 4

4. Hardware / Software Requirements 5

4.1. Hardware requirements 5

4.2. Software requirements 5

5. Creating an EDR Test Program – 6 Basic Steps. 6

5.1. Step 1 of 6: Reference the Dynamic Link Library (DLL) 6

5.1.1. Example: Referencing the EDR DLL’s in Visual Studio .NET. 6

5.1.2. Example: Referencing the EDR DLL’s in Agilent VEE.. 6

5.1.3. Example: Referencing the EDR DLL’s in NI LabVIEW 6

5.2. Step 2 of 6: Create the Instrument object. 7

5.2.1. .NET object creation 7

5.2.2. Example code snippet: .NET Object creation (C# .NET syntax) 7

5.2.3. COM object creation: 7

5.2.4. Example code snippet: COM object creation (C# syntax) 8

5.3. Step 3 of 6: Configure the measurement setup parameters 8

5.3.1. Generic N4010A Measurement Setup Parameters. 8

5.3.2. Measurement Specific N4010A Setup Parameters. 8

5.3.3. Bluetooth EDR Device Setup Parameters. 8

5.3.4. Example code snippet: Measurement setup (C# syntax) 8

5.4. Step 4 of 6: Perform the Test. 8

5.4.1. Measurement Run() Methods 8

5.4.2. Measurement CalcResults() Methods. 9

5.4.3. Example code snippet: Running of measurement (C# syntax) 9

5.5. Step 5 of 6: Get the measurement results. 9

5.5.1. Example code snippet: Retrieval of measurement results (C# syntax) 9

5.5.2. EDR Receiver Measurements 9

5.5.3. Example code snippet: Setup and Running of the N4010A Signal Generator (C# syntax) 9

5.6. Step 6 of 6: Close the session.. 10

5.6.1. Example code snippet: Disposal of session (C# syntax) 10


3. Introduction

DLL Compatibility

As part of the installation from the N4010A EDR Test Driver CD there are two programming interfaces installed:

  • COM DLL

  • .NET DLL

This gives you the option to use the DLL type that is compatible with your software development environment.

The COM and .NET programming interfaces are compatible with any programming language that supports either COM or .NET DLL programming. Example programs are available for:

  • Microsoft Visual C# .NET (COM & .NET)

  • Microsoft Visual Basic .NET (COM & .NET)

  • Microsoft Visual Basic 6.0 (COM)

  • Microsoft Visual C++ 6.0 (COM)

  • Visual Basic Script (COM)

  • Agilent VEE 6.2 (COM)

  • Agilent VEE 7.0 (COM & .NET)

  • LabVIEW 6 (COM)

  • LabVIEW 7.1 (COM & .NET)


Agilent.N4010.EdrDriver.EnumsHierarchy

Agilent N4010A Bluetooth EDR Driver

Agilent.N4010.EdrDriver.Enums Hierarchy

System.Object
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Agilent.N4010.EdrDriver.Enums.CalculatedEdrPacketType
Agilent.N4010.EdrDriver.Enums.ExpectedPacketType
Agilent.N4010.EdrDriver.Enums.IFBandwidth
Agilent.N4010.EdrDriver.Enums.TransmitPacketType
Agilent.N4010.EdrDriver.Enums.TriggerSlope
Agilent.N4010.EdrDriver.Enums.TriggerStyle

See Also

Agilent.N4010.EdrDriver.Enums Namespace


InvalidParameterException Hierarchy

System.Object
Exception
ApplicationException
InvalidParameterException
AcquisitionOffsetTimeOutOfRangeException
AcquisitionTimeOutOfRangeException
ChannelFrequencyOutOfRangeException
EdrOutputLevelOutOfRangeException
ExpectedPacketTypeOutOfRangeException
FrequencyOutOfRangeException
IFBandwidthOutOfRangeException
InvalidFileNameException
MeasurementTimeoutOutOfRangeException
OutputLevelOutOfRangeException
PacketNumberOutOfRangeException
PowerLevelOutOfRangeException
TriggerIdleOutOfRangeException
TriggerLevelOutOfRangeException
TriggerSlopeOutOfRangeException
TriggerStyleOutOfRangeException

See Also

InvalidParameterException Class | InvalidParameterException Members | Agilent.N4010.EdrDriver.Exceptions Namespace


Agilent.N4010.EdrDriver.ExceptionsHierarchy

Agilent N4010A Bluetooth EDR Driver

Agilent.N4010.EdrDriver.Exceptions Hierarchy

System.Object
System.Exception ---- System.Runtime.Serialization.ISerializable
System.ApplicationException
Agilent.N4010.EdrDriver.Exceptions.ArbitraryWaveformGeneratorException
Agilent.N4010.EdrDriver.Exceptions.CannotConnectToInstrumentException
Agilent.N4010.EdrDriver.Exceptions.FailedToStartException
Agilent.N4010.EdrDriver.Exceptions.FileStoreFullException
Agilent.N4010.EdrDriver.Exceptions.InternalErrorException
Agilent.N4010.EdrDriver.Exceptions.InvalidParameterException
Agilent.N4010.EdrDriver.Exceptions.AcquisitionOffsetTimeOutOfRangeException
Agilent.N4010.EdrDriver.Exceptions.AcquisitionTimeOutOfRangeException
Agilent.N4010.EdrDriver.Exceptions.ChannelFrequencyOutOfRangeException
Agilent.N4010.EdrDriver.Exceptions.EdrOutputLevelOutOfRangeException
Agilent.N4010.EdrDriver.Exceptions.ExpectedPacketTypeOutOfRangeException
Agilent.N4010.EdrDriver.Exceptions.FrequencyOutOfRangeException
Agilent.N4010.EdrDriver.Exceptions.IFBandwidthOutOfRangeException
Agilent.N4010.EdrDriver.Exceptions.InvalidFileNameException
Agilent.N4010.EdrDriver.Exceptions.MeasurementTimeoutOutOfRangeException
Agilent.N4010.EdrDriver.Exceptions.OutputLevelOutOfRangeException
Agilent.N4010.EdrDriver.Exceptions.PacketNumberOutOfRangeException
Agilent.N4010.EdrDriver.Exceptions.PowerLevelOutOfRangeException
Agilent.N4010.EdrDriver.Exceptions.TriggerIdleOutOfRangeException
Agilent.N4010.EdrDriver.Exceptions.TriggerLevelOutOfRangeException
Agilent.N4010.EdrDriver.Exceptions.TriggerSlopeOutOfRangeException
Agilent.N4010.EdrDriver.Exceptions.TriggerStyleOutOfRangeException
Agilent.N4010.EdrDriver.Exceptions.MeasurementErrorException
Agilent.N4010.EdrDriver.Exceptions.MeasurementRunningException
Agilent.N4010.EdrDriver.Exceptions.MeasurementTimeoutException
Agilent.N4010.EdrDriver.Exceptions.MissingSegmentFileException
Agilent.N4010.EdrDriver.Exceptions.NoIQData
Agilent.N4010.EdrDriver.Exceptions.NoSequenceFileSelectedException
Agilent.N4010.EdrDriver.Exceptions.NoSuchInstrumentFileException
Agilent.N4010.EdrDriver.Exceptions.NotLicensedException
Agilent.N4010.EdrDriver.Exceptions.ResultNotAvailableException
Agilent.N4010.EdrDriver.Exceptions.SourceActiveException
Agilent.N4010.EdrDriver.Exceptions.SourceInactiveException
Agilent.N4010.EdrDriver.Exceptions.VisaException

See Also

Agilent.N4010.EdrDriver.Exceptions Namespace


Agilent.N4010.EdrDriver.GeneratorHierarchy

Agilent N4010A Bluetooth EDR Driver

Agilent.N4010.EdrDriver.Generator Hierarchy

System.Object
Agilent.N4010.EdrDriver.Generator.Generator

See Also

Agilent.N4010.EdrDriver.Generator Namespace


Agilent.N4010.EdrDriver.Measurements.ResultsHierarchy

Agilent N4010A Bluetooth EDR Driver

Agilent.N4010.EdrDriver.Measurements.Results Hierarchy

System.Object
Agilent.N4010.EdrDriver.Measurements.Results.tDataMarkersResults
System.ValueType
Agilent.N4010.EdrDriver.Measurements.Results.tBasebandIqResults
Agilent.N4010.EdrDriver.Measurements.Results.tCarrierStabilityModulationAccuracyResults
Agilent.N4010.EdrDriver.Measurements.Results.tDifferentialPhaseEncodingResults
Agilent.N4010.EdrDriver.Measurements.Results.tPowerResults
Agilent.N4010.EdrDriver.Measurements.Results.tRelativePowerResults

See Also

Agilent.N4010.EdrDriver.Measurements.Results Namespace


Agilent.N4010.EdrDriver.Measurements.SettingsHierarchy

Agilent N4010A Bluetooth EDR Driver

Agilent.N4010.EdrDriver.Measurements.Settings Hierarchy

System.Object
Agilent.N4010.EdrDriver.Measurements.Settings.tBasebandIqSettings
Agilent.N4010.EdrDriver.Measurements.Settings.tCarrierStabilityModulationAccuracySettings
Agilent.N4010.EdrDriver.Measurements.Settings.tDifferentialPhaseEncodingSettings
Agilent.N4010.EdrDriver.Measurements.Settings.tPowerSettings
Agilent.N4010.EdrDriver.Measurements.Settings.tRelativePowerSettings

See Also

Agilent.N4010.EdrDriver.Measurements.Settings Namespace


Agilent.N4010.EdrDriver.MeasurementsHierarchy

Agilent N4010A Bluetooth EDR Driver

Agilent.N4010.EdrDriver.Measurements Hierarchy

System.Object
Agilent.N4010.EdrDriver.Measurements.DataMarkers
Agilent.N4010.EdrDriver.Measurements.MeasurementBaseFrontEnd
Agilent.N4010.EdrDriver.Measurements.BasebandIq
Agilent.N4010.EdrDriver.Measurements.CarrierStabilityModulationAccuracy
Agilent.N4010.EdrDriver.Measurements.DifferentialPhaseEncoding
Agilent.N4010.EdrDriver.Measurements.Power
Agilent.N4010.EdrDriver.Measurements.RelativePower
Agilent.N4010.EdrDriver.Measurements.MeasurementSetup

See Also

Agilent.N4010.EdrDriver.Measurements Namespace


Agilent.N4010.EdrDriverHierarchy

Agilent N4010A Bluetooth EDR Driver

Agilent.N4010.EdrDriver Hierarchy

System.Object
Agilent.N4010.EdrDriver.Instrument
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Agilent.N4010.EdrDriver.DebugLogEventHandler
System.EventArgs
Agilent.N4010.EdrDriver.DebugLogEventArgs
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Agilent.N4010.EdrDriver.DebugLogSeverity

See Also

Agilent.N4010.EdrDriver Namespace


Creating an EDR Test Program – 6 Basic Steps

There are six basic steps in creating an EDR test program using the N4010A EDR COM or .NET DLL.

  1. Reference the Dynamic Link Library’s (DLL’s)

  2. Create the instrument object

  3. Configure the measurement setup parameters

  4. Run the measurement

  5. Get the measurement results

  6. Close the session

Steps 3 to 5 can be repeated as many times as required for a full test of the Bluetooth EDR device. There is no need to follow step 1 “Create” and step 6 “Dispose” of the Instrument object for each measurement. The “Create” and “Dispose” stages are only required if the PC or the N4010A is power cycled.

It is advisable during software test development / debugging to catch any potential exceptions due to potential errors in the programming or setup. For example the use of Try / Catch Blocks in Microsoft Visual Studio .NET, allows the program to catch any errors without the program aborting. Additionally, if the program aborts due to an exception the “Dispose” method may not be reached and the N4010A can be left in an unknown state.


Hardware Requirements

  • N4010A instrument with Options 101 Bluetooth

  • / 105 or 106

  • Connection between the N4010A and the PC via LAN or USB

  • A Bluetooth Enhanced Date Rate (EDR) device

  • Connection between Bluetooth EDR device RF port and N4010A RF In/Out

For more information refer to the Getting Started Guide.


Introduction

Welcome to Agilent

<Product Name>

Help

Help Revision Date: September 27, 2005

?? The following navigation links and supporting text are provided as an example. Customize the Welcome Topic to meet the needs of your help project. Note that the blue underlined text needs to be converted to actual hyperlinks. Currently it is just formatted as blue-underline text to look like hyperlinks. ??

This online help describes how to use the <Product Name>. The help is organized into the following sections:

Getting Help: Use this section if you want to learn how to get the most from this online help.

Getting Started: Use this section if you are new to <Product Name>.

How To...: Use this section if you want step-by-step procedures for performing the most common tasks with the <Product Name>.

Graphical User Interface Reference: Use this section if you want information on how to use the <Product Name>'s Graphical User Interface.

Developer Information: Use this section if you are a developer and want information on the <Product Name>'s Programming Interfaces.

Troubleshooting: Use this section if you have questions relating to installation, setup or use.

© Agilent Technologies, Inc. 2002


N4010A Getting Started with EDR Test Programming

sa

3

Release Status:

Andrew Smail

Wireless Networking Application Engineer

Getting Started with N4010A EDR Test Programming

Released

Original Author:

Revision Number:


Software Requirements

  • Installation of the N4010A EDR Test Driver

  • The Bluetooth Enhanced Data Rate device control software

  • Installation and experience in a programming environment, for example Microsoft C# .NET, Microsoft Visual Basic, Agilent VEE, or NI LabVIEW.